Bug 16199 - [3.4 regression] ICE while compiling apache 2.0.49
Summary: [3.4 regression] ICE while compiling apache 2.0.49
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 3.4.0
: P1 normal
Target Milestone: 3.4.2
Assignee: Eric Botcazou
URL:
Keywords:
: 16695 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-25 13:15 UTC by Olaf Klein
Modified: 2004-10-30 21:10 UTC (History)
2 users (show)

See Also:
Host: sparc-sun-solaris2.8
Target: sparc-sun-solaris2.8
Build: sparc-sun-solaris2.8
Known to work: 3.3.2 3.3.4 4.0.0
Known to fail: 3.4.0 3.4.1
Last reconfirmed: 2004-06-25 17:04:02


Attachments
Preprocessed source code which fails to compile (26.45 KB, text/plain)
2004-06-25 13:17 UTC, Olaf Klein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Klein 2004-06-25 13:15:42 UTC
nemrud1-e0:oklein:/kias/build/.build/httpd-2.0.49/srclib/apr/locks/unix$ gcc
-save-temps -pthreads  -g -O3 -m64 -DHAVE_CONFIG_H -DSOLARIS2=8
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT   -I../../include -I../../include/arch
-I../../include/arch/unix  -c proc_mutex.c
proc_mutex.c: In function `apr_proc_mutex_defname':
proc_mutex.c:771: internal compiler error: in force_nonfallthru_and_redirect, at
cfgrtl.c:1114
Comment 1 Olaf Klein 2004-06-25 13:17:53 UTC
Created attachment 6627 [details]
Preprocessed source code which fails to compile
Comment 2 Olaf Klein 2004-06-25 13:18:57 UTC
nemrud1-e0:oklein:/kias/build/.build/httpd-2.0.49/srclib/apr/locks/unix$ gcc -v
Reading specs from
/kias/kiastools/gcc3.4.0/bin/../lib/gcc/sparc-sun-solaris2.8/3.4.0/specs
Configured with: /kias/build/gcc-3.4.0/configure
--prefix=/opt/kiastools/gcc3.4.0
--with-libiconv-prefix=/opt/kiastools/libiconv1.8 : (reconfigured)
/kias/build/gcc-3.4.0/configure --prefix=/opt/kiastools/gcc3.4.0
--with-libiconv-prefix=/opt/kiastools/libiconv1.8
Thread model: posix
gcc version 3.4.0
Comment 3 Olaf Klein 2004-06-25 13:21:19 UTC
If I try to compile without -O3, for example with -O2, everything is fine.

Comment 4 Eric Botcazou 2004-06-25 17:04:02 UTC
Confirmed on the 3.4 branch, a regression from the 3.3 branch.
Comment 5 Eric Botcazou 2004-06-25 17:04:47 UTC
Investigating.
Comment 6 CVS Commits 2004-07-08 12:55:03 UTC
Subject: Bug 16199

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	ebotcazou@gcc.gnu.org	2004-07-08 12:54:53

Modified files:
	gcc            : ChangeLog 
	gcc/config/sparc: sparc.c 
	gcc/testsuite  : ChangeLog 
Added files:
	gcc/testsuite/gcc.c-torture/compile: 20040708-1.c 

Log message:
	PR target/16199
	* config/sparc/sparc.c (sparc_emit_set_symbolic_const64): When
	'temp' is zero, generate new pseudos as needed and emit the
	sequence of insns in single-assignment form.  Resync comments
	with code.
	(sparc_emit_set_const64): Pass zero as 'temp' argument to above
	function before reload.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=2.4376&r2=2.4377
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/sparc/sparc.c.diff?cvsroot=gcc&r1=1.312&r2=1.313
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.3952&r2=1.3953
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gcc.c-torture/compile/20040708-1.c.diff?cvsroot=gcc&r1=NONE&r2=1.1

Comment 7 CVS Commits 2004-07-08 13:01:22 UTC
Subject: Bug 16199

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	ebotcazou@gcc.gnu.org	2004-07-08 13:01:08

Modified files:
	gcc            : ChangeLog 
	gcc/config/sparc: sparc.c 
	gcc/testsuite  : ChangeLog 
Added files:
	gcc/testsuite/gcc.c-torture/compile: 20040708-1.c 

Log message:
	PR target/16199
	* config/sparc/sparc.c (sparc_emit_set_symbolic_const64): When
	'temp' is zero, generate new pseudos as needed and emit the
	sequence of insns in single-assignment form.  Resync comments
	with code.
	(sparc_emit_set_const64): Pass zero as 'temp' argument to above
	function before reload.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=2.2326.2.540&r2=2.2326.2.541
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/sparc/sparc.c.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.271.4.15&r2=1.271.4.16
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.3389.2.223&r2=1.3389.2.224
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gcc.c-torture/compile/20040708-1.c.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=NONE&r2=1.1.2.1

Comment 8 Eric Botcazou 2004-07-08 13:14:28 UTC
See http://gcc.gnu.org/ml/gcc-patches/2004-07/msg00771.html
Comment 9 Eric Botcazou 2004-07-25 09:44:23 UTC
*** Bug 16695 has been marked as a duplicate of this bug. ***