Bug 16005 - GridBagLayout resizes components incorrectly when weigthy value is set
Summary: GridBagLayout resizes components incorrectly when weigthy value is set
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: awt (show other bugs)
Version: unspecified
: P3 normal
Target Milestone: 0.91
Assignee: Thomas Fitzsimmons
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-15 16:47 UTC by rodimina
Modified: 2006-05-07 20:40 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-05-04 02:13:42


Attachments
This test program demonstates this bug (416 bytes, application/octet-stream)
2004-06-15 16:53 UTC, rodimina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rodimina 2004-06-15 16:47:06 UTC
If a container with GridBagLayout contains a component with a very small height,
(i.e height = 5) and weigthy value is set, then components aren't resized
correctly. It seems that they are all resized to size 5 in this case.
Comment 1 rodimina 2004-06-15 16:53:28 UTC
Created attachment 6532 [details]
This test program demonstates this bug
Comment 2 Sven de Marothy 2006-04-30 02:56:48 UTC
Is this fixed now? I can't quite see what the problem is with the test program?
Comment 3 Lillian Angel 2006-05-03 18:36:24 UTC
Fixed