Bug 15830 - --disable-nls doesn't disable nls
Summary: --disable-nls doesn't disable nls
Status: RESOLVED DUPLICATE of bug 11074
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on:
Reported: 2004-06-05 02:36 UTC by James McKelvey
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: alphaev56-unknown-linux-gnu
Target: alphaev56-unknown-linux-gnu
Build: alphaev56-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description James McKelvey 2004-06-05 02:36:05 UTC
Bootstrap fails in abi_check with undefined references to libintl*. This in
spite of the fact that --disable-nls was specified. Recent CVS.

alpha1:gcc-obj>uname -a
Linux alpha1 2.4.9-40 #1 Mon Sep 23 08:14:02 EDT 2002 alpha unknown

alpha1:gcc-obj>gcc -v
Reading specs from /usr/local/lib/gcc/alphaev56-unknown-linux-gnu/3.5.0/specs
Configured with: ../gcc/configure --verbose --enable-languages=c++
Thread model: posix
gcc version 3.5.0 20040207 (experimental)

alpha1:gcc-obj>alias CONFIGURECVS
alias CONFIGURECVS='../gcc/configure --verbose --enable-languages=c++

alpha1:gcc-obj>alias BUILD
alias BUILD='nice gmake CFLAGS='\''-O'\'' BOOT_CFLAGS='\''-O'\''
LIBCFLAGS='\''-g -O'\'' LIBCXXFLAGS='\''-g -O -fno-implicit-templates'\''

/home/mckelvey/software/gcc-obj/gcc/g++ -shared-libgcc
-B/home/mckelvey/software/gcc-obj/gcc/ -nostdinc++
-B/usr/local/alphaev56-unknown-linux-gnu/lib/ -isystem
/usr/local/alphaev56-unknown-linux-gnu/include -isystem
/usr/local/alphaev56-unknown-linux-gnu/sys-include -g -O2 -D_GLIBCXX_ASSERT
-ffunction-sections -fdata-sections -fmessage-length=0
-g -O2 -D_GNU_SOURCE -mieee -o abi_check abi_check.o 
-lm -Wl,--rpath -Wl,/home/mckelvey/software/gcc-obj/gcc -Wl,--rpath
undefined reference to `libintl_bindtextdomain'
undefined reference to `libintl_textdomain'
collect2: ld returned 1 exit status
gmake[4]: *** [abi_check] Error 1
gmake[4]: Leaving directory
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory
gmake[1]: *** [all-target-libstdc++-v3] Error 2
gmake[1]: Leaving directory `/usr/home/mckelvey/software/gcc-obj'
gmake: *** [bootstrap] Error 2
Comment 1 Andrew Pinski 2004-06-05 05:02:19 UTC
If I read the docs right this is the correct behavior as --disable-nls only disables the translation support 
in the error messages and not the use of libintl* in libstdc++:
The --enable-nls option enables Native Language Support (NLS), which lets GCC output diagnostics in 
languages other than American English. Native Language Support is enabled by default if not doing a 
canadian cross build. The --disable-nls option disables NLS. 
Comment 2 James McKelvey 2004-06-05 15:33:26 UTC
OK, I understand. I don't really want to disable NLS, I just want the bootstrap
to finish. (In the recent past, --disable-nls has helped in situations where I
had libintl problems.)

If that is not the solution, what is?
Comment 3 James McKelvey 2004-06-07 03:12:05 UTC
If I manually add -lintl to the Makefile, I can get abi_check to link and the
bootstrap to finish.
Comment 4 Andrew Pinski 2004-06-07 03:14:20 UTC
This is a dup of bug 11074.

*** This bug has been marked as a duplicate of 11074 ***