Bug 15710 - [4.0 Regression] ICE: tree check: expected class 'E', have 'c' (integer_cst) in make_class_data
Summary: [4.0 Regression] ICE: tree check: expected class 'E', have 'c' (integer_cst) ...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.0
Assignee: Tom Tromey
URL:
Keywords: ice-on-valid-code, patch
Depends on:
Blocks: 17574
  Show dependency treegraph
 
Reported: 2004-05-28 16:06 UTC by Anthony Green
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Green 2004-05-28 16:06:02 UTC
I get the following error building a new version of Ant with gcj.  I was able to
build this code 1 week ago.  No small test case yet, but the offending source is
the same as is found in bug 15708.


$ gcj --encoding=ISO-8859-1 -Wno-deprecated
--classpath=upstream/src/main:../jakarta-ant/upstream/src/main -fassume-compiled
-g -O2 -MT upstream/src/main/org/apache/tools/ant/taskdefs/DefBase.lo -MD -MP
-MF upstream/src/main/org/apache/tools/ant/taskdefs/.deps/DefBase.Tpo -c
../jakarta-ant/upstream/src/main/org/apache/tools/ant/taskdefs/DefBase.java 
-fPIC -o upstream/src/main/org/apache/tools/ant/taskdefs/.libs/DefBase.o
../jakarta-ant/upstream/src/main/org/apache/tools/ant/taskdefs/DefBase.java:150:
internal compiler error: tree check: expected class 'E', have 'c' (integer_cst)
in make_class_data, at java/class.c:1508
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 1 Andrew Pinski 2004-05-28 17:17:16 UTC
Could be related to PR 11188, or bug 12755.
Comment 2 Tom Tromey 2004-09-22 23:30:33 UTC
Compiling this file works fine for me with my current compiler.
I suspect it was either fixed by a patch elsewhere, or by one
of the other bug fixes in my tree.

Could you try again with cvs head?  And if it fails, append
a stack trace from jc1?
Comment 3 Tom Tromey 2004-09-27 22:26:26 UTC
FWIW I was able to reproduce this today using
cvs trunk gcj and cvs trunk rhug.
Comment 4 Tom Tromey 2004-09-27 22:54:51 UTC
FYI, I'm testing a patch.
The problem seems to be that we can see an unloaded superinterface
in add_miranda_methods.
Comment 5 Andrew Pinski 2004-09-28 16:45:24 UTC
Patch here: <http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02876.html>.
Comment 6 CVS Commits 2004-09-28 18:27:33 UTC
Subject: Bug 15710

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	tromey@gcc.gnu.org	2004-09-28 18:27:25

Modified files:
	gcc/java       : ChangeLog class.c 

Log message:
	PR java/15710:
	* class.c (add_miranda_methods): Load superinterface if not
	already loaded.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/ChangeLog.diff?cvsroot=gcc&r1=1.1468&r2=1.1469
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/class.c.diff?cvsroot=gcc&r1=1.207&r2=1.208

Comment 7 Tom Tromey 2004-09-28 18:27:53 UTC
Fix checked in.