Bug 15582 - Almost all libstdc++ testsuite programs fail to produce executable
Summary: Almost all libstdc++ testsuite programs fail to produce executable
Status: RESOLVED DUPLICATE of bug 11074
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-22 03:31 UTC by James McKelvey
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: alphaev56-unknown-linux-gnu
Target: alphaev56-unknown-linux-gnu
Build: alphaev56-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James McKelvey 2004-05-22 03:31:28 UTC
Recent CVS built fine, but almost every program in the libstdc++ testsuite
failed with "failure to produce executable."

Below is one example. Could it be related to 15546?

FAIL: 17_intro/header_cassert.cc (test for excess errors)
Excess errors:
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_bindtextdomain'
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_textdomain'
collect2: ld returned 1 exit status

alpha1:PD>uname -a
Linux alpha1 2.4.9-40 #1 Mon Sep 23 08:14:02 EDT 2002 alpha unknown

Built with:

alpha1:PD>gcc -v
Reading specs from /usr/local/lib/gcc/alphaev56-unknown-linux-gnu/3.5.0/specs
Configured with: ../gcc/configure --verbose --enable-languages=c++
Thread model: posix
gcc version 3.5.0 20040207 (experimental)

alpha1:PD>alias CONFIGURECVS
alias CONFIGURECVS='../gcc/configure  --verbose --enable-languages=c++'

alpha1:PD>alias BUILD
alias BUILD='nice gmake CFLAGS='\''-O'\'' BOOT_CFLAGS='\''-O'\''
LIBCFLAGS='\''-g -O'\'' LIBCXXFLAGS='\''-g -O -fno-implicit-templates'\''
bootstrap'
Comment 1 Andrew Pinski 2004-05-22 04:15:39 UTC
Most likely not related, it looks like you have libintl installed so gcc is picking up the headers for it but 
not the library instead it is picking the since libintl is part of glibc the library is really unnessarry and 
causing this problem.
Comment 2 Benjamin Kosnik 2004-05-24 16:40:34 UTC
These results look fine. It's not exactly the same as your bug report, but very
close. Can you confirm that this is still an issue?

Results for 3.5.020040524(experimental) testsuite on alphaev67-unknown-linux-gnu
http://gcc.gnu.org/ml/gcc-testresults/2004-05/msg01118.html
Comment 3 Benjamin Kosnik 2004-05-25 15:51:26 UTC
re-open if not the case.
Comment 4 James McKelvey 2004-05-27 05:28:50 UTC
(In reply to comment #3)> re-open if not the case.OK, I'm having trouble bootstrapping now. I'll retest as soon as possible.Thanks.
Comment 5 James McKelvey 2004-06-07 03:19:46 UTC
Still fails with unresolved references to libintl. I can't figure out where to
add -lintl to make it succeed. Note that the problem is similar to 15830.

Test Run By mckelvey on Sun Jun  6 20:06:43 2004
Native configuration is alphaev56-unknown-linux-gnu

		=== libstdc++ tests ===

Schedule of variations:
    unix

Running target unix
Using /usr/local/share/dejagnu/baseboards/unix.exp as board description file for
target.
Using /usr/local/share/dejagnu/config/unix.exp as generic interface file for
target.
Using /home/mckelvey/software/gcc/libstdc++-v3/testsuite/config/default.exp as
tool-and-target-specific interface file.
Running
/home/mckelvey/software/gcc/libstdc++-v3/testsuite/libstdc++-dg/normal.exp ...
LD_LIBRARY_PATH =
:/home/mckelvey/software/gcc-obj/gcc:/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/./libstdc++-v3/src/.libs:/lib:/usr/local/lib:$TOTALVIEW/lib
In v3-list-tests
blddir =
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/./libstdc++-v3
tests_file =
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/./libstdc++-v3/testsuite/testsuite_files
Executing on host: /home/mckelvey/software/gcc-obj/gcc/g++ -shared-libgcc
-B/home/mckelvey/software/gcc-obj/gcc/ -nostdinc++
-L/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src
-L/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs
-B/usr/local/alphaev56-unknown-linux-gnu/bin/
-B/usr/local/alphaev56-unknown-linux-gnu/lib/ -isystem
/usr/local/alphaev56-unknown-linux-gnu/include -isystem
/usr/local/alphaev56-unknown-linux-gnu/sys-include -g -O2 -D_GLIBCXX_ASSERT
-ffunction-sections -fdata-sections -fmessage-length=0
-DLOCALEDIR="/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/po/share/locale"
-nostdinc++
-I/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/include/alphaev56-unknown-linux-gnu
-I/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/include
-I/home/mckelvey/software/gcc/libstdc++-v3/libsupc++
-I/home/mckelvey/software/gcc/libstdc++-v3/libsupc++
-I/home/mckelvey/software/gcc/libstdc++-v3/include/backward
-I/home/mckelvey/software/gcc/libstdc++-v3/testsuite
/home/mckelvey/software/gcc/libstdc++-v3/testsuite/17_intro/header_cassert.cc   
-include bits/stdc++.h 
-L/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/./libstdc++-v3/testsuite
-lv3test -lm   -o ./header_cassert.exe    (timeout = 300)
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_bindtextdomain'
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_textdomain'
collect2: ld returned 1 exit status
compiler exited with status 1
output is:
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_bindtextdomain'
/home/mckelvey/software/gcc-obj/alphaev56-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so:
undefined reference to `libintl_textdomain'
collect2: ld returned 1 exit status

Comment 6 Andrew Pinski 2004-06-07 03:27:40 UTC
Actually it is the same issue, the problem is located in the libstdc++ makefiles, libstdc++ should be 
linked in with libintl so this is a dup of bug 11074.

*** This bug has been marked as a duplicate of 11074 ***