Bug 15515 - Use gmp mpfr functionality instead of reimplementing standard functions
Summary: Use gmp mpfr functionality instead of reimplementing standard functions
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.0.0
: P2 enhancement
Target Milestone: 4.0.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 15952
  Show dependency treegraph
 
Reported: 2004-05-18 13:06 UTC by Tobias Schlüter
Modified: 2004-08-26 00:16 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-05-18 13:11:18


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Schlüter 2004-05-18 13:06:51 UTC
In the thread starting here http://gcc.gnu.org/ml/fortran/2004-05/msg00246.html
ways of making gfortran's arithmetic code more maintainable are explored.
An overview of functions reimplementing gmp's mpfr functionality can be found here:
http://gcc.gnu.org/ml/gcc-patches/2003-09/msg00912.html
This bug is meant to track any efforts in that direction.
Comment 1 Andrew Pinski 2004-05-18 13:11:18 UTC
Confirmed.
Comment 2 Steve Kargl 2004-06-24 05:09:09 UTC
I've started to look at changing GMP to MPFR.  One item to note that
the use of the 130-bit GMP mpf_t types eliminates the need to consider
mix-mode math.  This reduces the complexity in arith.c, simplify.c, etc
because the Fortran promotion rules are simply ignored.  For a more
detailed discussion see http://gcc.gnu.org/ml/fortran/2004-06/msg00187.html
Comment 3 Steve Kargl 2004-07-16 04:37:46 UTC
Lest it gets lost, I did the grunt work.  It can be found
here: http://gcc.gnu.org/ml/fortran/2004-07/msg00005.html
Comment 4 Steve Kargl 2004-07-21 04:57:40 UTC
Updated patch at http://gcc.gnu.org/ml/gcc-patches/2004-07/msg02001.html
Comment 5 Steve Kargl 2004-08-26 00:06:16 UTC
This PR can be closed.  See gcc/gcc/fortran/ChangeLog
entry "2004-08-06  Steven G. Kargl  <kargls@comcast.net>"
for details.

Comment 6 Andrew Pinski 2004-08-26 00:11:42 UTC
Yes this is fixed now.