Bug 15488 - possibly insufficient file permissions for executing test suite
Summary: possibly insufficient file permissions for executing test suite
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.4.1
: P2 normal
Target Milestone: 3.4.2
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-17 08:20 UTC by jbeulich
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail: 3.4.1 4.0.0
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbeulich 2004-05-17 08:20:07 UTC
Since testsuite/lib/libstdc++.exp just copies over $srcdir/data/*.t[sx]t (which
in TCL appearantly implies copying permissions [but not owner/group]), the files
may all end up non-writable if the source tree was set so. I'd suggest

--- /usr/local/src/gcc-3.4.0/libstdc++-v3/testsuite/lib/libstdc++.exp	2004-03-18
18:38:09.000000000 +0100
+++ 3.4.0/libstdc++-v3/testsuite/lib/libstdc++.exp	2004-05-14 13:42:44.000000000
+0200
@@ -71,6 +71,8 @@
                 file copy -force $dirname/$symlink $dstdir
             }
         }
+        set basename [file tail $f]
+        file attributes $dstdir/$basename -permissions a+w
     }
 }
Comment 1 Benjamin Kosnik 2004-05-18 01:18:44 UTC
Same with this. Send it in as a patch: it looks like it may indeed be a bug,
depending on how the originating sources are assigned permissions.

-benjamin
Comment 2 CVS Commits 2004-05-18 18:42:36 UTC
Subject: Bug 15488

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	bkoz@gcc.gnu.org	2004-05-18 18:42:28

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/scripts: create_testsuite_files 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	2004-05-18  Jan Beulich  <jbeulich@novell.com>
	
	PR libstdc++/15489
	* scripts/create_testsuite_files: Also find source files through
	symbolic links.
	
	2004-05-18  Jan Beulich  <jbeulich@novell.com>
	
	PR libstdc++/15488
	* testsuite/lib/libstdc++.exp: Make test files writable.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2482&r2=1.2483
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/scripts/create_testsuite_files.diff?cvsroot=gcc&r1=1.1&r2=1.2
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&r1=1.20&r2=1.21

Comment 3 CVS Commits 2004-05-19 23:36:46 UTC
Subject: Bug 15488

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	bkoz@gcc.gnu.org	2004-05-19 23:36:39

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/scripts: create_testsuite_files 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	2004-05-19  Jan Beulich  <jbeulich@novell.com>
	
	PR libstdc++/15489
	* scripts/create_testsuite_files: Also find source files through
	symbolic links.
	
	2004-05-19  Jan Beulich  <jbeulich@novell.com>
	
	PR libstdc++/15488
	* testsuite/lib/libstdc++.exp: Make test files writable.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.2224.2.108&r2=1.2224.2.109
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/scripts/create_testsuite_files.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.1&r2=1.1.22.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.15.4.3&r2=1.15.4.4

Comment 4 Andrew Pinski 2004-05-19 23:51:05 UTC
Fixed.
Comment 5 jbeulich 2004-07-12 12:35:59 UTC
This isn't really fixed. The change to use remote_download in v3-copy-files made
this patch unnecessary, and the way it was applied it actually became
counter-productive since other than the submitted patch the one applied changes
the mode of the source files (in the source tree, that is) rather than that of
the destination files. If the user running the testsuite doesn't have sufficient
rights to do so, the whole testsuite run now fails.
In the light of all that, the patch simply needs to be backed out in both
mainline and 3_4-branch.
Comment 6 CVS Commits 2004-07-19 23:11:07 UTC
Subject: Bug 15488

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	bkoz@gcc.gnu.org	2004-07-19 23:11:03

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	2004-07-19  Benjamin Kosnik  <bkoz@redhat.com>
	
	PR libstdc++/15488
	* testsuite/lib/libstdc++.exp (v3-copy-files): Revert.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2580&r2=1.2581
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&r1=1.21&r2=1.22

Comment 7 Benjamin Kosnik 2004-07-19 23:12:26 UTC
I'm reverting this patch on both branches:

PR libstdc++/15488

-benjamin
Comment 8 CVS Commits 2004-07-19 23:35:41 UTC
Subject: Bug 15488

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	bkoz@gcc.gnu.org	2004-07-19 23:35:37

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	2004-07-19  Benjamin Kosnik  <bkoz@redhat.com>
	
	PR libstdc++/15488
	* testsuite/lib/libstdc++.exp (v3-copy-files): Revert.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.2224.2.146&r2=1.2224.2.147
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.15.4.4&r2=1.15.4.5

Comment 9 Benjamin Kosnik 2004-07-20 00:16:13 UTC
Can I close this?
Comment 10 jbeulich 2004-07-20 08:52:12 UTC
I believe so.
Comment 11 Andrew Pinski 2004-07-20 14:43:40 UTC
So closing as fixed.