Bug 15475 - [3.3/3.4/4.0 Regression] gcj bytecode miscompilation in System.java
Summary: [3.3/3.4/4.0 Regression] gcj bytecode miscompilation in System.java
Status: RESOLVED DUPLICATE of bug 16789
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 3.4.3
Assignee: Not yet assigned to anyone
URL:
Keywords: wrong-code
Depends on:
Blocks: 17574
  Show dependency treegraph
 
Reported: 2004-05-16 13:01 UTC by Anthony Green
Modified: 2004-09-21 22:25 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work: 3.0.4
Known to fail: 3.3.3 3.2.2 3.4.0 4.0.0
Last reconfirmed: 2004-05-19 23:06:54


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Green 2004-05-16 13:01:27 UTC
System.java contains this:

  public static void runFinalizersOnExit(boolean finalizeOnExit)
  {
    Runtime.getRuntime().runFinalizersOnExit(finalizeOnExit);
  }
                                                                                
But gcj -C is only producing this:

Method name:"runFinalizersOnExit" public static Signature: 158=(boolean)void
Attribute "Code", length:47, max_stack:0, max_locals:1, code_length:5
  0: invokestatic #146=<Method java.lang.Runtime.getRuntime ()java.lang.Runtime>
 3: pop
  4: return
Attribute "LineNumberTable", length:6, count: 1
  line: 528 at pc: 0
Attribute "LocalVariableTable", length:12, count: 1
  slot#0: name: 159=finalizeOnExit, type: 160=boolean (pc: 0 length: 5)
Attribute "Deprecated", length:0
Comment 1 Andrew Pinski 2004-05-19 23:06:51 UTC
Confirmed a regression from 3.0.4.
Comment 2 Giovanni Bajo 2004-06-06 03:58:08 UTC
Retargeting to 3.4.1, being a regression on that release branch.
Comment 3 Mark Mitchell 2004-06-12 21:56:13 UTC
Postponed until GCC 3.4.2.
Comment 4 Bryce McKinlay 2004-07-31 19:30:59 UTC
Most likely related to PR java/16789
Comment 5 Mark Mitchell 2004-08-23 20:58:05 UTC
Postponed until GCC 3.4.3.
Comment 6 Tom Tromey 2004-09-21 22:25:37 UTC

*** This bug has been marked as a duplicate of 16789 ***