Bug 15367 - namespace-qualified function name not treated as dependent
Summary: namespace-qualified function name not treated as dependent
Status: RESOLVED DUPLICATE of bug 15144
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.0
: P1 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on:
Reported: 2004-05-10 19:06 UTC by Jason Merrill
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Known to work:
Known to fail:
Last reconfirmed:

testcase (108 bytes, text/plain)
2004-05-10 19:07 UTC, Jason Merrill

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Merrill 2004-05-10 19:06:14 UTC
In the attached testcase, g++ treats ::f as non-dependent even though the call
has type-dependent arguments.  I think this is wrong, and the EDG compiler
agrees with me, though the standard seems to say that only function names that
are plain identifiers can be dependent names.

This breaks OpenOffice.
Comment 1 Jason Merrill 2004-05-10 19:07:10 UTC
Created attachment 6252 [details]
Comment 2 Andrew Pinski 2004-05-10 19:18:33 UTC
This is a dup of bug 15144 which GDR says that 3.4.0 is correct behavior.  Read  Giovanni Bajo's 
explaination also his is really clear about why this is invalid code.

*** This bug has been marked as a duplicate of 15144 ***