User account creation filtered due to spam.

Bug 15093 - make bootstrap fails to configure libffi
Summary: make bootstrap fails to configure libffi
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libffi (show other bugs)
Version: 3.4.0
: P2 normal
Target Milestone: 3.4.1
Assignee: Not yet assigned to anyone
URL:
Keywords: build
: 15029 15110 15215 15216 15315 15451 16141 16217 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-04-23 10:44 UTC by olle
Modified: 2005-02-23 13:46 UTC (History)
10 users (show)

See Also:
Host: alpha-dec-osf5.1
Target: alpha-dec-osf5.1
Build: alpha-dec-osf5.1
Known to work:
Known to fail:
Last reconfirmed: 2004-04-23 15:17:30


Attachments
Output from make (89.57 KB, application/gzip)
2004-04-23 10:47 UTC, olle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description olle 2004-04-23 10:44:05 UTC
System: Compaq/HP  Tru64 Unix 5.1B
Make : Gnu make 3.80
Compiler used: gcc-3.3.2
Compiler to bootstrap: gcc-3.4.0

checking whether we are using GNU C... (cached) yes
checking whether /usr/users/olle/objdir/gcc/xgcc -B/usr/users/olle/objdir/gcc/
-B/usr/local/alpha-dec-osf5.1/bin/ -B/usr/local/alpha-dec-osf5.1/lib/ -isystem
/usr/local/alpha-dec-osf5.1/include -isystem
/usr/local/alpha-dec-osf5.1/sys-include accepts -g... (cached) yes
/usr/users/olle/gcc-3.4.0/libffi/configure: test: argument expected
make[1]: *** [configure-target-libffi] Error 1
make[1]: Leaving directory `/usr/users/olle/objdir'
make: *** [bootstrap] Error 2
Comment 1 olle 2004-04-23 10:47:27 UTC
Created attachment 6148 [details]
Output from make
Comment 2 Andrew Pinski 2004-04-23 11:42:35 UTC
Can you try with setting CONFIG_SHELL to say bash or ksh?
Comment 3 olle 2004-04-23 15:13:33 UTC
I did use tsch as my shell.

Setting CONFIG_SHELL to bash made the bootstrap to work. However it complains 
about 

/usr/users/olle/gcc-3.4.0/libffi/configure: line 2500: test: !=: unary 
operator expected
/usr/users/olle/gcc-3.4.0/libffi/configure: line 2501: test: !=: unary operator
 expected

but this is nonfatal.
Comment 4 Andrew Pinski 2004-04-23 15:17:30 UTC
Confirmed then thanks.
Comment 5 Andrew Pinski 2004-04-24 13:22:42 UTC
*** Bug 15110 has been marked as a duplicate of this bug. ***
Comment 6 Joe Buck 2004-04-27 00:39:35 UTC
The suggestion to recommend a CONFIG_SHELL of bash is the wrong fix; this just
hides the bug.  Jim Wilson pointed out the real problem in

http://gcc.gnu.org/ml/gcc/2004-04/msg01227.html

There is a proposed patch at

http://gcc.gnu.org/ml/gcc-patches/2004-04/msg01754.html

That's for the 3.4 branch.  I have verified that it works on Compaq Tru64.
For the trunk, the corresponding change to

libffi/configure.ac

should be made.
Comment 7 CVS Commits 2004-04-27 05:10:32 UTC
Subject: Bug 15093

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	wilson@gcc.gnu.org	2004-04-27 05:10:21

Modified files:
	libffi         : ChangeLog configure.in configure 

Log message:
	Patch from Joe Buck for alpha-dec-osf5.1 build failure.
	Bug 15093
	* configure.in: Test for existence of mmap and sys/mman.h before
	checking blacklist.  Fix suggested by Jim Wilson.
	* configure: Regenerate.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.153.4.5&r2=1.153.4.6
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/configure.in.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.48&r2=1.48.2.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/configure.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.55&r2=1.55.4.1

Comment 8 CVS Commits 2004-04-27 05:41:49 UTC
Subject: Bug 15093

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	wilson@gcc.gnu.org	2004-04-27 05:41:45

Modified files:
	libffi         : ChangeLog configure configure.ac 

Log message:
	Bug 15093
	* configure.ac: Test for existence of mmap and sys/mman.h before
	checking blacklist.  Fix suggested by Jim Wilson.
	* configure: Regenerate.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/ChangeLog.diff?cvsroot=gcc&r1=1.172&r2=1.173
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/configure.diff?cvsroot=gcc&r1=1.58&r2=1.59
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/configure.ac.diff?cvsroot=gcc&r1=1.2&r2=1.3

Comment 9 Andrew Pinski 2004-04-27 11:25:57 UTC
Fixed for 3.4.1.
Comment 10 Andrew Pinski 2004-04-30 00:41:58 UTC
*** Bug 15215 has been marked as a duplicate of this bug. ***
Comment 11 Andrew Pinski 2004-04-30 00:54:23 UTC
*** Bug 15216 has been marked as a duplicate of this bug. ***
Comment 12 Andrew Pinski 2004-05-06 12:43:32 UTC
*** Bug 15315 has been marked as a duplicate of this bug. ***
Comment 13 Andrew Pinski 2004-05-15 00:20:23 UTC
*** Bug 15451 has been marked as a duplicate of this bug. ***
Comment 14 Wolfgang Bangerth 2004-05-25 18:26:20 UTC
*** Bug 15029 has been marked as a duplicate of this bug. ***
Comment 15 Andrew Pinski 2004-06-22 16:47:08 UTC
*** Bug 16141 has been marked as a duplicate of this bug. ***
Comment 16 Andrew Pinski 2004-06-26 00:19:49 UTC
*** Bug 16217 has been marked as a duplicate of this bug. ***