User account creation filtered due to spam.

Bug 14725 - gcc-3.3.3-hammer has issues with -fstrict-aliasing
Summary: gcc-3.3.3-hammer has issues with -fstrict-aliasing
Status: RESOLVED DUPLICATE of bug 21920
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: unknown
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-25 01:28 UTC by lu_zero
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: powerpc-unknown-linux-gnu
Target: powerpc-unknown-linux-gnu
Build: powerpc-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Vanilla source (5.82 KB, text/plain)
2004-03-25 01:29 UTC, lu_zero
Details
Preprocessed source (40.59 KB, text/plain)
2004-03-25 01:30 UTC, lu_zero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lu_zero 2004-03-25 01:28:28 UTC
The code that before compiled just fine with -fstrict-aliasing (included in -O2)
now misbehaves. I'm not sure if that is a bug or is just happening what was
warned since ages about type-punning.

a code snip little enough could be find in openssl-0.9.7d: 
crypto/pem/pem_lib.c : 481

if (!load_iv((unsigned char **)&header,&(cipher->iv[0]),enc->iv_len)) return(0);

Interesting enough that happens just on the hammer tree (tested against the
20040322 cvs)
Comment 1 lu_zero 2004-03-25 01:29:21 UTC
Created attachment 5996 [details]
Vanilla source
Comment 2 lu_zero 2004-03-25 01:30:53 UTC
Created attachment 5997 [details]
Preprocessed source
Comment 3 Andrew Pinski 2004-03-25 02:26:41 UTC
Not a bug, for some reason the hammer branch does more scheduling which causes errors in code like 
this to show up.
Comment 4 Andrew Pinski 2005-06-05 08:41:51 UTC
Reopening to ...
Comment 5 Andrew Pinski 2005-06-05 08:42:16 UTC
Mark as a dup of bug 21920.

*** This bug has been marked as a duplicate of 21920 ***