Bug 14664 - [3.4 Regression] All gcj-built programs SEGV on startup
Summary: [3.4 Regression] All gcj-built programs SEGV on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: gcc
Classification: Unclassified
Component: libgcj (show other bugs)
Version: 3.4.0
: P2 normal
Target Milestone: 3.4.3
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-20 15:50 UTC by Anthony Green
Modified: 2004-10-21 01:11 UTC (History)
2 users (show)

See Also:
Host: alphaev6-unknown-linux-gnu
Target: alphaev6-unknown-linux-gnu
Build: alphaev6-unknown-linux-gnu
Known to work:
Known to fail: 3.4.1
Last reconfirmed: 2004-09-30 03:17:16


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Green 2004-03-20 15:50:25 UTC
All gcj-built programs SEGV on startup.


[green@killians alphaev6-unknown-linux-gnu]$ ~/GDB/b/gdb/gdb HelloWorld
GNU gdb 2004-03-20-cvs
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "alphaev6-unknown-linux-gnu"...Using host
libthread_db library "/lib/libthread_db.so.1".
 
(gdb) run
Starting program:
/home/green/GCC/3.4/alphaev6-unknown-linux-gnu/gcc/alphaev6-unknown-linux-gnu/HelloWorld
 
Program received signal SIGSEGV, Segmentation fault.
0x000002000000fa80 in ?? ()
(gdb) where
#0  0x000002000000fa80 in ?? ()
warning: Hit heuristic-fence-post without finding
warning: enclosing function for address 0x2000000fa80
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable).  In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post' command.
 
Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
#1  0x000002000000fbb0 in ?? ()
warning: Hit heuristic-fence-post without finding
warning: enclosing function for address 0x2000000fbb0
Previous frame identical to this frame (corrupt stack?)
(gdb)
Comment 1 Andrew Pinski 2004-03-20 17:16:53 UTC
IIRC this is a regression.
Comment 2 Andrew Pinski 2004-04-27 19:26:05 UTC
Confirmed by looking into the testresults.
Comment 3 Mark Mitchell 2004-06-04 20:22:00 UTC
Not a showstopper.

Tom -- do you want to take a look at this?
Comment 4 Mark Mitchell 2004-08-29 18:49:24 UTC
Postponed until GCC 3.4.3.
Comment 5 Andrew Pinski 2004-09-24 21:54:26 UTC
Isn't there a patch for this somewhere (or I am remember another problem).
<http://gcc.gnu.org/ml/java-patches/2004-q3/msg00906.html>
This looks like it is fixed on the mainline: <http://gcc.gnu.org/ml/gcc-testresults/2004-09/
msg01071.html>.
Comment 6 Tom Tromey 2004-09-29 21:15:18 UTC
rth tells me that this is fixed on the trunk.
Not sure what to do about the bug disposition;
I don't know whether or not the problem lingers
on the 3.4 branch.
Comment 7 Andrew Pinski 2004-09-30 03:17:15 UTC
So mark this only as a 3.4 regression because the other problem which effected libjava on alpha on the 
mainline is fixed.
Comment 8 Richard Henderson 2004-10-21 01:11:27 UTC
                === libjava tests ===


Running target unix
WARNING: program timed out.
FAIL: linking simple
FAIL: initexc execution - gij test
FAIL: initexc execution - gij test

                === libjava Summary ===

# of expected passes            3256
# of unexpected failures        3
# of expected failures          11
# of untested testcases         10