Bug 14536 - [3.4 Regression] make dvi broken under gcc-3.4
Summary: [3.4 Regression] make dvi broken under gcc-3.4
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: 3.4.0
: P2 critical
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 13820
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 17:09 UTC by Kelley Cook
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelley Cook 2004-03-11 17:09:57 UTC
Problem:

On a recent commit to the branch, HP inadvertently used autoconf 2.58 to
regenerate the gcc directory which unfortunately contains a bug in which it
outputs a relative pathname when an absolute one is requested; autoconf 2.59 was
released a few days later because of this bug.

"make dvi" requires absolute path names (PR13820), so it no longer works with
the current 3.4 branch.
---------
Steps to recreate:

$ ../{relative-path-to-src}/configure
$ make maybe-configure-gcc
$ cd gcc
$ make dvi
-------------
Proposed action:

Regenerate the gcc directory with autoheader/autoconf 2.57 which is the
documented version in gcc-3.4's install.texi.

Note: Mainline now uses autoconf 2.59, so it does not have the bug is not
present there.
Comment 1 Mark Mitchell 2004-03-11 17:16:21 UTC
Subject: Re:  New: make dvi broken under gcc-3.4

kcook at gcc dot gnu dot org wrote:

> Regenerate the gcc directory with autoheader/autoconf 2.57 which is the
> documented version in gcc-3.4's install.texi.

That's fine, and such a patch is pre-approved.

In fact, if you can also change configure.in to forbid the use of 2.58, 
that's pre-approved as well.

Comment 2 CVS Commits 2004-03-11 21:43:09 UTC
Subject: Bug 14536

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	kcook@gcc.gnu.org	2004-03-11 21:43:07

Modified files:
	gcc            : ChangeLog configure config.in 

Log message:
	2004-03-11  Kelley Cook  <kcook@gcc.gnu.org>
	
	PR other/14536
	* configure: Regenerated with autoconf 2.57.
	* config.in: Regenerated with autoheader 2.57.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=2.2326.2.329&r2=2.2326.2.330
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/configure.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.794.2.11&r2=1.794.2.12
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config.in.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.181.4.1&r2=1.181.4.2

Comment 3 Kelley Cook 2004-03-11 21:46:10 UTC
Suggested patch checked into 3.4 branch.  Issue fixed.