Bug 14431 - "configure --with-libiconv-prefix=" is ignored
Summary: "configure --with-libiconv-prefix=" is ignored
Status: RESOLVED DUPLICATE of bug 12596
Alias: None
Product: gcc
Classification: Unclassified
Component: libgcj (show other bugs)
Version: 3.4.0
: P3 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-04 15:50 UTC by Artem A. Kozarezov
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host: i386-unknown-freebsd5.1
Target: i386-unknown-freebsd5.1
Build: i386-unknown-freebsd5.1
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem A. Kozarezov 2004-03-04 15:50:44 UTC
FreeBSD (both 4 and 5) have libiconv installed under /usr/local,
yet gcc thinks that there is no libiconv installed,
even when "--with-libiconv-prefix=/usr/local" configure option is present.

Workaround is to:
8<----------------------------->8
cd /usr/include
ln -s /usr/local/include/iconv.h
cd /usr/lib
ln -s /usr/local/lib/libiconv.so
cd /usr/bin
ln -s /usr/local/bin/iconv
8<----------------------------->8
After that "HAVE_ICONV" becomes properly defined
in libjava/include/config.h ...

Although this problem is global for a whole GCC,
I file this bug under libgcj becouse I didn't found a topic for
configure problems, and it seems that libgcj is primary
user of libiconv, and I primarily concerned about libiconv
available in libgcj...

I've encountered the same problem in gcc-3.2.2, so it is not a new one.
Comment 1 Andrew Pinski 2004-03-04 16:17:38 UTC
This is a dup of bug 12596.

*** This bug has been marked as a duplicate of 12596 ***