User account creation filtered due to spam.

Bug 14166 - [3.3 Regression] GCC-3.3.3 build fails with internal compiler error
Summary: [3.3 Regression] GCC-3.3.3 build fails with internal compiler error
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.3.3
: P2 critical
Target Milestone: 3.3.4
Assignee: Richard Earnshaw
URL:
Keywords: ice-on-valid-code
: 14182 14257 14338 14405 14968 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-16 19:00 UTC by Pablo Bleyer Kocik
Modified: 2005-07-23 22:49 UTC (History)
7 users (show)

See Also:
Host: i686-pc-cygwin
Target: arm-unknown-elf
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-02-17 11:37:34


Attachments
t-arm-elf (1.15 KB, text/plain)
2004-02-16 20:10 UTC, Pablo Bleyer Kocik
Details
Tentative patch (backport from mainline) (991 bytes, patch)
2004-02-17 13:14 UTC, Richard Earnshaw
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo Bleyer Kocik 2004-02-16 19:00:26 UTC
Hello. I am getting the following error trying to build a cross compiler for 
arm-elf under CygWin. It seems there is an error in the dp-bit.c file with 
THUMB mode.

 Please, tell me if you need more information.

 Regards.

make[1]: Entering directory `/c/gabuild/gcc-build/libiberty'
make[2]: Entering directory `/c/gabuild/gcc-build/libiberty/testsuite'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/c/gabuild/gcc-build/libiberty/testsuite'
make[1]: Leaving directory `/c/gabuild/gcc-build/libiberty'
make[1]: Entering directory `/c/gabuild/gcc-build/gcc'
(cd intl && make all)
make[2]: Entering directory `/c/gabuild/gcc-build/gcc/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/c/gabuild/gcc-build/gcc/intl'
make GCC_FOR_TARGET="/c/gabuild/gcc-build/gcc/xgcc -B/c/gabuild/gcc-
build/gcc/ -B/c/gnuarm-3.3.3/arm-elf/bin/ -B/c/gnuarm-3.3.3/arm-elf/lib/ -
isystem /c/gnuarm-3.3.3/arm-elf/include" \
  BUILD_PREFIX="" BUILD_PREFIX_1="loser-" \
  AR_FOR_TARGET="arm-elf-ar" \
  AR_CREATE_FOR_TARGET="arm-elf-ar  rc" \
  AR_FLAGS_FOR_TARGET="" \
  CFLAGS="-g -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-
prototypes -Wtraditional -pedantic -Wno-long-long " \
  RANLIB_FOR_TARGET="arm-elf-ranlib" \
  RANLIB_TEST_FOR_TARGET="[ -f arm-elf-ranlib ] || ( [ "i686-pc-cygwin" = "arm-
unknown-elf" ] && [ -f /usr/bin/ranlib -o -f /bin/ranlib ] )" \
  NM_FOR_TARGET="/c/gnuarm-3.3.3/arm-elf/bin/nm.exe" AWK="gawk" \
  LIBGCC2_CFLAGS="-O2  -DIN_GCC -DCROSS_COMPILE   -W -Wall -Wwrite-strings -
Wstrict-prototypes -Wmissing-prototypes -isystem ./include  -Dinhibit_libc -
fno-inline -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc" \
  INCLUDES="-I. -I. -I../../gcc-3.3.3/gcc -I../../gcc-3.3.3/gcc/. -I../../gcc-
3.3.3/gcc/config -I../../gcc-3.3.3/gcc/../include" \
  CONFIG_H="config.h auto-host.h ../../gcc-
3.3.3/gcc/../include/ansidecl.h ../../gcc-3.3.3/gcc/config/i386/xm-
cygwin.h ../../gcc-3.3.3/gcc/config/dbxelf.h ../../gcc-
3.3.3/gcc/config/elfos.h ../../gcc-3.3.3/gcc/config/arm/unknown-
elf.h ../../gcc-3.3.3/gcc/config/arm/elf.h ../../gcc-
3.3.3/gcc/config/arm/aout.h ../../gcc-3.3.3/gcc/config/arm/arm.h ../../gcc-
3.3.3/gcc/defaults.h ../../gcc-3.3.3/gcc/defaults.h insn-constants.h insn-
flags.h" MACHMODE_H="machmode.h machmode.def ../../gcc-
3.3.3/gcc/config/arm/arm-modes.def" \
  LIB1ASMSRC='arm/lib1funcs.asm' \
  MAKEOVERRIDES= \
  -f libgcc.mk all
make[2]: Entering directory `/c/gabuild/gcc-build/gcc'
for d in libgcc thumb libgcc/thumb be libgcc/be fpu libgcc/fpu interwork 
libgcc/interwork nofmult libgcc/nofmult fpu/interwork libgcc/fpu/interwork 
fpu/nofmult libgcc/fpu/nofmult be/fpu libgcc/be/fpu be/interwork 
libgcc/be/interwork be/nofmult libgcc/be/nofmult be/fpu/interwork 
libgcc/be/fpu/interwork be/fpu/nofmult libgcc/be/fpu/nofmult thumb/be 
libgcc/thumb/be thumb/interwork libgcc/thumb/interwork thumb/be/interwork 
libgcc/thumb/be/interwork; do \
  if [ -d $d ]; then true; else /bin/sh ../../gcc-3.3.3/gcc/mkinstalldirs $d; 
fi; \
done
if [ -f stmp-dirs ]; then true; else touch stmp-dirs; fi
/c/gabuild/gcc-build/gcc/xgcc -B/c/gabuild/gcc-build/gcc/ -B/c/gnuarm-
3.3.3/arm-elf/bin/ -B/c/gnuarm-3.3.3/arm-elf/lib/ -isystem /c/gnuarm-3.3.3/arm-
elf/include -O2  -DIN_GCC -DCROSS_COMPILE   -W -Wall -Wwrite-strings -Wstrict-
prototypes -Wmissing-prototypes -isystem ./include  -Dinhibit_libc -fno-
inline -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc -I. -I. -
I../../gcc-3.3.3/gcc -I../../gcc-3.3.3/gcc/. -I../../gcc-3.3.3/gcc/config -
I../../gcc-3.3.3/gcc/../include -DFINE_GRAINED_LIBRARIES -mthumb -DL_pack_df -
c dp-bit.c -o libgcc/thumb/_pack_df.o
dp-bit.c: In function `__pack_d':
dp-bit.c:411: error: insn does not satisfy its constraints:
(insn:HI 333 331 561 0xa12a1b0 (set (reg:HI 3 r3 [109])
        (mem:HI (label_ref 584) [0 S2 A16])) 169 {*thumb_movhi_insn} 
(insn_list:REG_DEP_ANTI 330 (insn_list:REG_DEP_OUTPUT 329 (nil)))
    (expr_list:REG_EQUIV (const_int 2047 [0x7ff])
        (nil)))
dp-bit.c:411: internal compiler error: in extract_constrain_insn_cached, at 
recog.c:2090
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[2]: *** [libgcc/thumb/_pack_df.o] Error 1
make[2]: Leaving directory `/c/gabuild/gcc-build/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory `/c/gabuild/gcc-build/gcc'
make: *** [all-gcc] Error 2
Comment 1 Giovanni Bajo 2004-02-16 19:50:10 UTC
We need to know your configuration line and your host compiler version. Also, 
would you please provide a preprocessed source for dp-bit.c, generated with -E? 
Comment 2 Pablo Bleyer Kocik 2004-02-16 20:10:13 UTC
Subject: Re:  GCC-3.3.3 build fails with internal
  compiler error


  Hello.

  Host GCC version is: gcc (GCC) 3.3.1 (cygming special)

  Configuration options were:

  --target=arm-elf --enable-interwork --enable-multilib --with-newlib 
--with-headers=../newlib-1.12.0/newlib/libc/include --enable-languages="c,c++"

  I am including the modified t-arm-elf file.

  I will post the preprocessed GCC output once I figure out how to do it.

  Regards.


At 16:50 2004-02-16, you wrote:

>------- Additional Comments From giovannibajo at libero dot it  2004-02-16 
>19:50 -------
>We need to know your configuration line and your host compiler version. Also,
>would you please provide a preprocessed source for dp-bit.c, generated 
>with -E?
>
>--
>            What    |Removed                     |Added
>----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |WAITING
>
>
>http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14166
>
>------- You are receiving this mail because: -------
>You reported the bug, or are watching the reporter.
Comment 3 Pablo Bleyer Kocik 2004-02-16 20:10:16 UTC
Created attachment 5757 [details]
t-arm-elf
Comment 4 Richard Earnshaw 2004-02-17 11:35:30 UTC
Don't need any further information, a standard arm-elf cross fails with the same
problem -- oops.

This was caused by a back-porting of RTH's patch to validate mem constraints: a
back-port of

http://gcc.gnu.org/ml/gcc-patches/2004-01/msg01156.html

will probably be required to address this.
Comment 5 Richard Earnshaw 2004-02-17 13:14:42 UTC
Created attachment 5759 [details]
Tentative patch (backport from mainline)

With this patch the compiler now builds correctly -- still running full tests
Comment 6 Pablo Bleyer Kocik 2004-02-17 14:42:23 UTC
Subject: Re:  [3.3 Regression] GCC-3.3.3 build fails
  with internal compiler error


  Nice. I will try to test a build with that patch.

  Regards.

At 10:14 2004-02-17, you wrote:

>------- Additional Comments From rearnsha at gcc dot gnu dot 
>org  2004-02-17 13:14 -------
>Created an attachment (id=5759)
>  --> (http://gcc.gnu.org/bugzilla/attachment.cgi?id=5759&action=view)
>Tentative patch (backport from mainline)
>
>With this patch the compiler now builds correctly -- still running full tests
>
>--
>
>
>http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14166
>
>------- You are receiving this mail because: -------
>You reported the bug, or are watching the reporter.

Comment 7 Andrew Pinski 2004-02-18 05:12:37 UTC
*** Bug 14182 has been marked as a duplicate of this bug. ***
Comment 8 Gabriel Dos Reis 2004-02-22 14:57:24 UTC
(In reply to comment #5)
> Created an attachment (id=5759)
> Tentative patch (backport from mainline)
> 
> With this patch the compiler now builds correctly -- still running full tests

Richard --

The branch is open again.

Thanks,

-- Gaby
Comment 9 Richard Earnshaw 2004-02-23 11:55:15 UTC
*** Bug 14257 has been marked as a duplicate of this bug. ***
Comment 10 CVS Commits 2004-02-25 11:50:35 UTC
Subject: Bug 14166

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	rearnsha@gcc.gnu.org	2004-02-25 11:50:27

Modified files:
	gcc            : ChangeLog 
	gcc/config/arm : arm.h arm.md 

Log message:
	PR target/14166
	* arm.h (THUMB_GO_IF_LEGITIMATE_ADDRESS): Only allow constant pool
	references from SImode.
	* arm.md (thumb_movhi_insn): Don't allow minipool references.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.16114.2.906&r2=1.16114.2.907
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/arm/arm.h.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.168&r2=1.168.2.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/arm/arm.md.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.113.2.3&r2=1.113.2.4

Comment 11 Richard Earnshaw 2004-02-25 11:51:20 UTC
Patch applied.
Comment 12 Andrew Pinski 2004-02-26 01:22:21 UTC
*** Bug 14302 has been marked as a duplicate of this bug. ***
Comment 13 Andrew Pinski 2004-02-29 00:23:57 UTC
*** Bug 14338 has been marked as a duplicate of this bug. ***
Comment 14 Andrew Pinski 2004-03-03 16:58:32 UTC
*** Bug 14405 has been marked as a duplicate of this bug. ***
Comment 15 Andrew Pinski 2004-04-15 16:07:23 UTC
*** Bug 14968 has been marked as a duplicate of this bug. ***