Bug 14082 - Not Implemented: arrays of strings
Summary: Not Implemented: arrays of strings
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: tree-ssa
: P2 enhancement
Target Milestone: tree-ssa
Assignee: Paul Brook
URL:
Keywords: ice-on-valid-code, rejects-valid
: 14727 (view as bug list)
Depends on: 13253
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 12:46 UTC by Richard Biener
Modified: 2004-06-16 13:51 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-04-04 07:33:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Biener 2004-02-09 12:46:14 UTC
For g77 backward compatibility arrays of strings need to be implemented, as the
following code doesn't compile otherwise:

      subroutine test
      character chnum(0:9)*1
      data chnum /'0','1','2','3','4','5','6','7','8','9'/
      end

this is a regression towards g77.
Comment 1 Andrew Pinski 2004-02-14 20:36:23 UTC
confirmed.
Comment 2 Paul Brook 2004-02-27 17:53:24 UTC
Basically another dup of Bug 13253. 
Leaving it open because it also involves initialization via a DATA statement. 
Comment 3 Andrew Pinski 2004-03-25 04:46:06 UTC
*** Bug 14727 has been marked as a duplicate of this bug. ***
Comment 4 Paul Brook 2004-04-04 23:30:48 UTC
Fixed.