Bug 13993 - [3.4 Regression] Relative path as srcdir causes problem
Summary: [3.4 Regression] Relative path as srcdir causes problem
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 3.4.4
Assignee: Not yet assigned to anyone
URL:
Keywords: build, patch
: 15668 16363 16835 17768 17769 19306 19751 20609 24463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-03 08:43 UTC by Paul N. Hilfinger
Modified: 2005-10-20 21:42 UTC (History)
10 users (show)

See Also:
Host: alphaev67-dec-osf5.1
Target: alphaev67-dec-osf5.1
Build: alphaev67-dec-osf5.1
Known to work:
Known to fail: 3.4.1 4.0.0
Last reconfirmed: 2004-06-02 20:18:23


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul N. Hilfinger 2004-02-03 08:43:19 UTC
Configuring the head version of GCC with 

  CC=gcc ../../src/gcc-head/configure --enable-languages="c" \
--prefix=$HOME/obj/gcc-head/install

causes a problem after

make bootstrap
make install

Specifically, within the gcc subdirectory, 'make install' looks for install-sh
in ../../src/gcc-head, the top-level source directory, which is wrong (should be
../../../src/gcc-head.  This is a change from earlier versions (3.3.2, for
example).  It is causes by the definition of INSTALL in the top-level
Makefile.in, which gets passed down to and overrides the (correct) definition
of INSTALL in the gcc subdirectory.  

If the use of relative paths when invoking configure is to be deprecated, there
should be a warning.  Better still, revert to the previous definition of INSTALL
or otherwise convert to an absolute pathname for INSTALL, as previous versions
did.
Comment 1 Andrew Pinski 2004-04-21 20:53:03 UTC
Hmm this worked in 3.4.0 because I just did a build.
Comment 2 Andrew Pinski 2004-04-25 20:27:50 UTC
Can you try again?
Comment 3 Andrew Pinski 2004-05-26 13:53:41 UTC
This worked for me, can you try again?
Comment 4 Andrew Pinski 2004-06-02 20:18:42 UTC
*** Bug 15668 has been marked as a duplicate of this bug. ***
Comment 5 Mark Mitchell 2004-06-09 19:32:10 UTC
Andrew reports success.  Until more details are provided, I'm closing this PR.
Comment 6 Andrew Pinski 2004-07-04 19:38:29 UTC
I know this is a bug now, the reason why it works for me is because I compatiable "install" installed.
Comment 7 Andrew Pinski 2004-07-04 19:38:46 UTC
*** Bug 16363 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Pinski 2004-07-30 15:20:51 UTC
*** Bug 16835 has been marked as a duplicate of this bug. ***
Comment 9 Mark Mitchell 2004-08-29 19:09:42 UTC
Postponed until GCC 3.4.3.
Comment 10 Andrew Pinski 2004-10-01 12:31:19 UTC
*** Bug 17769 has been marked as a duplicate of this bug. ***
Comment 11 Andrew Pinski 2004-10-01 12:31:26 UTC
*** Bug 17768 has been marked as a duplicate of this bug. ***
Comment 12 Andrew Pinski 2004-10-23 19:22:23 UTC
Patch posted here: <http://gcc.gnu.org/ml/gcc-patches/2004-10/msg01987.html>.

This is also known as <http://sources.redhat.com/bugzilla/show_bug.cgi?id=179>.
Comment 13 Andrew Pinski 2004-10-23 20:31:16 UTC
Daniel since your patch fixes this bug, could you look into backporting it to the 3.4 branch?
Comment 14 Mark Mitchell 2004-11-01 00:46:21 UTC
Postponed until GCC 3.4.4.
Comment 15 Andrew Pinski 2005-01-07 03:13:07 UTC
*** Bug 19306 has been marked as a duplicate of this bug. ***
Comment 16 Andrew Pinski 2005-02-02 14:30:39 UTC
*** Bug 19751 has been marked as a duplicate of this bug. ***
Comment 17 Daniel Jacobowitz 2005-03-08 17:31:31 UTC
Fixed on 3.4 and 4.0 branches.
Comment 18 Andrew Pinski 2005-03-23 20:35:19 UTC
*** Bug 20609 has been marked as a duplicate of this bug. ***
Comment 19 Andrew Pinski 2005-10-20 21:42:15 UTC
*** Bug 24463 has been marked as a duplicate of this bug. ***