User account creation filtered due to spam.

Bug 13966 - default template arguments ignored in template template parameters
Summary: default template arguments ignored in template template parameters
Status: RESOLVED DUPLICATE of bug 9737
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-01 22:41 UTC by Jim Apple
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: x86 linux
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Apple 2004-02-01 22:41:35 UTC
template<typename T, typename U = int>
struct foo {};
                                                                                
template<template <typename> class TT>
struct bar {};
                                                                                
bar<foo> x;

compiles, see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=4205#comment_text_8
Comment 1 Andrew Pinski 2004-02-01 22:52:28 UTC
This is a dup of bug 9737.

*** This bug has been marked as a duplicate of 9737 ***