Bug 13774 - Member variable cleared in virtual multiple inheritance class
Summary: Member variable cleared in virtual multiple inheritance class
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3.2
: P2 critical
Target Milestone: 3.3.3
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-20 18:03 UTC by Stuart Hastings
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Source file to recreate the bug (369 bytes, text/plain)
2004-01-20 18:05 UTC, Stuart Hastings
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Hastings 2004-01-20 18:04:01 UTC
We have a code example with a complex virtual inheritance hierarchy - it has
worked with previous gcc, 3.0 and above, but after installing Fedora the code
crashes. It appears that a pointer gets cleared for no apparent reason and this
causes the crash. We have managed to reproduce the crash with the short file
that I will attach.


Gcc version:
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit --host=i386-redhat-linux
Thread model: posix
gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)

Compile line is:
mini: mini.cc
        g++ -o mini mini.cc -lstdc++

System is Fedora core 1:
Linux aethon.com 2.4.22-1.2115.nptl #1 Wed Oct 29 15:42:51 EST 2003 i686 i686
i386 GNU/Linux
Comment 1 Stuart Hastings 2004-01-20 18:05:27 UTC
Created attachment 5537 [details]
Source file to recreate the bug
Comment 2 Wolfgang Bangerth 2004-01-20 18:52:13 UTC
This works for me with 3.2.3, 3.3.3-pre, and 3.4 of last week. Maybe 
someone with a debian box can verify. 
 
W. 
Comment 3 Dara Hazeghi 2004-01-20 19:01:14 UTC
Confirmed bug with stock 3.3.2 build. Must've been fixed since on branch and mainline.