Bug 13477 - Bootstrap failure: gcc/gcc/combine.c:10294: warning: 'mask' might be used uninitialized in this function
Summary: Bootstrap failure: gcc/gcc/combine.c:10294: warning: 'mask' might be used uni...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: tree-ssa
: P2 critical
Target Milestone: tree-ssa
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-23 12:32 UTC by wanderer
Modified: 2004-01-07 13:36 UTC (History)
1 user (show)

See Also:
Host: i386-unknown-freebsd5.1
Target: i386-unknown-freebsd5.1
Build: i386-unknown-freebsd5.1
Known to work:
Known to fail:
Last reconfirmed: 2003-12-29 18:37:33


Attachments
t.log.gz (28.28 KB, application/octet-stream)
2003-12-25 07:54 UTC, wanderer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wanderer 2003-12-23 12:32:18 UTC
I can't bootstrap tree-ssa branch CVS gcc at FeeBSD 5.1:

using both system compiler gcc (GCC) 3.2.2 [FreeBSD] 20030205 (release)
and mainline CVS gcc;

using both binutils version 2.13.2 [FreeBSD] 2002-11-27
and mainline CVS binutils.

Last time when i can bootstrap tree-ssa breanch GCC is 2003.12.11

Bootstrap error messages:
---8X----------------------------------------
stage1/xgcc -Bstage1/ -B/home/wanderer/pkg/gcc/i386-unknown-freebsd5.1/bin/ -
c   -g -O2  -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-
prototypes -pedantic -Wno-long-long -Wold-style-definition -Werror -fno-
common   -DHAVE_CONFIG_H    -I. -I. -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/. -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/../include -I../intl -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/../libbanshee/libcompat -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/../libbanshee -
I/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/../libbanshee/points-
to  /home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/combine.c -o combine.o
/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/combine.c: In function 
`simplify_comparison':

/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/gcc/combine.c:10294: 
warning: 'mask' might be used uninitialized in this function
gmake[2]: *** [combine.o] Ошибка 1
gmake[2]: Leaving directory `/usr/home/wanderer/pkg/build/gcc/gcc'
gmake[1]: *** [stage2_build] Ошибка 2
gmake[1]: Leaving directory `/usr/home/wanderer/pkg/build/gcc/gcc'
gmake: *** [bootstrap] Ошибка 2
---X8---------------------------
Comment 1 Andrew Pinski 2003-12-23 18:10:19 UTC
This definitely a problem as hash is defined as: <unsigned HOST_WIDE_INT mask = 
GET_MODE_MASK (mode);>.
Comment 2 Andrew Pinski 2003-12-24 21:11:08 UTC
I cannot reproduce this on powerpc-apple-darwin, what options did you pass to 
configure?
Comment 3 Andrew Pinski 2003-12-25 04:16:43 UTC
I see some else can bootstrap so closing.
<http://gcc.gnu.org/ml/gcc-testresults/2003-12/msg01060.html>.
Comment 4 wanderer 2003-12-25 07:54:45 UTC
Subject: Re:  Bootstrap failure: gcc/gcc/combine.c:10294: warning: 'mask' might be used uninitialized in this function

Recheck with update tree-ssa CVS version.
Result: bootstrap broken with same error. :(
I am use misc. binutils/gcc installed combinations - no difference.

> I cannot reproduce this on powerpc-apple-darwin, what options did you pass
to
> configure?
>
/home/wanderer/pkg/build/gcc/src/gcc_ssa/gcc/configure --prefix=/home/wander
er/pkg/gcc --with-local-prefix=/home/wanderer/pkg/gcc --with-gxx-include-dir
=/home/wanderer/pkg/gcc/include/g++ --enable-threads=posix --with-gnu-as --w
ith-gnu-ld --enable-languages=c++

> uname -a
FreeBSD make.cc.rsu.ru 5.1-CURRENT FreeBSD 5.1-CURRENT #1: Wed Jul  2
18:40:58 MSD 2003
and@make.cc.rsu.ru:/usr/obj/usr/src/sys/make.p3.CURRENT.2003-06-25  i386

> ld --version
GNU ld version 2.13.2 [FreeBSD] 2002-11-27

Last check (5 min before mail writing) with
> gcc -v
Reading specs from
/usr/home/wanderer/pkg/gcc/bin/../lib/gcc/i386-unknown-freebsd5.1/3.4/specs
Configured with:
/home/wanderer/pkg/build/gcc/src/gcc/gcc/configure --prefix=/home/wanderer/p
kg/gcc --with-local-prefix=/home/wanderer/pkg/gcc --with-gxx-include-dir=/ho
me/wanderer/pkg/gcc/include/g++ --enable-threads=posix --with-gnu-as --with-
gnu-ld --enable-languages=c,c++
Thread model: posix
gcc version 3.4 20031217 (experimental)

But same result with
> /usr/bin/gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.2.2 [FreeBSD] 20030205 (release)

I attach log file configure+make bootstrap process.
Comment 5 wanderer 2003-12-25 07:54:50 UTC
Created attachment 5368 [details]
t.log.gz
Comment 6 Andrew Pinski 2003-12-29 18:31:34 UTC
Reopening even though there is something wrong here.
Comment 7 Andrew Pinski 2003-12-29 18:37:32 UTC
Another report of it: <http://gcc.gnu.org/ml/gcc/2003-12/msg01384.html>.
Comment 8 Andrew Pinski 2004-01-06 18:17:55 UTC
Should be fixed by:
	* tree-ssa-dom.c (tree_ssa_dominator_optimize): Correctly handle
	the case where an edge we wish to redirect is split by the out of SSA
	code.
Comment 9 wanderer 2004-01-07 13:36:07 UTC
I successfully bootstrap tree-ssa branch GCC with this patch first time after  
2003.12.12.

And then i think bug really fixed. :)