Bug 13468 - [4.0 Regression] interpret.cc should register ffi closure stubs
Summary: [4.0 Regression] interpret.cc should register ffi closure stubs
Status: RESOLVED DUPLICATE of bug 18036
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 3.4.0
: P2 critical
Target Milestone: 4.0.0
Assignee: Tom Tromey
URL:
Keywords:
: 13496 (view as bug list)
Depends on:
Blocks: 17574
  Show dependency treegraph
 
Reported: 2003-12-22 21:01 UTC by Mark Wielaard
Modified: 2004-10-21 13:41 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-08-14 06:46:50


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Wielaard 2003-12-22 21:01:42 UTC
interpret.cc doesn't function correctly when compiled with unit-at-a-time
This prevents e.g. eclipse to run with gij.

The problem is analyzed in the following message:
http://gcc.gnu.org/ml/java/2003-11/msg00321.html
Comment 1 Andrew Pinski 2003-12-22 21:04:56 UTC
Confirmed, a regression also, right?
Comment 2 Tom Tromey 2003-12-30 00:20:34 UTC
*** Bug 13496 has been marked as a duplicate of this bug. ***
Comment 3 Tom Tromey 2004-01-15 01:55:33 UTC
I sent some email to Bryce to see if he is planning to fix this
for 3.4.  (He's got a patch for various StackTrace problems which
should also address this PR.)

If his patch isn't going in 3.4 I will implement a workaround
in the Makefile.
Comment 5 Tom Tromey 2004-01-21 23:58:41 UTC
Workaround checked in.
Bryce's real fix will go in on the trunk at some later date.
Comment 6 Andrew Pinski 2004-01-21 23:59:59 UTC
Reopening as it is not fixed on the trunk yet and we should remember about it.
Comment 7 Andrew Pinski 2004-10-14 22:38:21 UTC
I think this was fixed by:
        2004-10-13  Andrew Haley  <aph@redhat.com>
        
        * interpret.cc (_Jv_InterpMethod::run): Initialize
        _Jv_StartOfInterpreter.
        (_Jv_StartOfInterpreter, _Jv_EndOfInterpreter): Functions removed.
        (_Jv_StartOfInterpreter, _Jv_EndOfInterpreter): New variables.
        * gnu/gcj/runtime/natStackTrace.cc (fillInStackTrace): Use
        _Unwind_FindEnclosingFunction to discover whether PC is within the
        interpreter.
Comment 8 Andrew Haley 2004-10-21 13:41:57 UTC

*** This bug has been marked as a duplicate of 18036 ***
Comment 9 CVS Commits 2005-01-05 09:59:19 UTC
Subject: Bug 13468

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-rhl-branch
Changes by:	jakub@gcc.gnu.org	2005-01-05 09:59:01

Modified files:
	libjava        : ChangeLog Makefile.am Makefile.in interpret.cc 
	libjava/gnu/gcj/runtime: natStackTrace.cc 

Log message:
	2004-12-13  Jakub Jelinek  <jakub@redhat.com>
	
	Revert:
	2004-01-21  Tom Tromey  <tromey@redhat.com>
	PR java/13468:
	* Makefile.in: Rebuilt.
	* Makefile.am (interpret.lo): New target.
	
	2004-10-18  Andrew Haley  <aph@redhat.com>
	
	PR java/18036:
	* gnu/gcj/runtime/natStackTrace.cc (fillInStackTrace): Reorganize
	and correct logic used to find interpreter.
	
	2004-10-13  Andrew Haley  <aph@redhat.com>
	
	* interpret.cc (_Jv_InterpMethod::run): Initialize
	_Jv_StartOfInterpreter.
	(_Jv_StartOfInterpreter, _Jv_EndOfInterpreter): Functions removed.
	(_Jv_StartOfInterpreter, _Jv_EndOfInterpreter): New variables.
	* gnu/gcj/runtime/natStackTrace.cc (fillInStackTrace): Use
	_Unwind_FindEnclosingFunction to discover whether PC is within the
	interpreter.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-rhl-branch&r1=1.2562.2.16.2.14&r2=1.2562.2.16.2.15
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/Makefile.am.diff?cvsroot=gcc&only_with_tag=gcc-3_4-rhl-branch&r1=1.354.2.3.2.4&r2=1.354.2.3.2.5
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/Makefile.in.diff?cvsroot=gcc&only_with_tag=gcc-3_4-rhl-branch&r1=1.378.2.3.2.4&r2=1.378.2.3.2.5
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/interpret.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_4-rhl-branch&r1=1.40.20.1&r2=1.40.20.2
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/gnu/gcj/runtime/natStackTrace.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_4-rhl-branch&r1=1.6&r2=1.6.22.1