Bug 13377 - [3.4 regression] unexpected behavior of namespace usage directive
Summary: [3.4 regression] unexpected behavior of namespace usage directive
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3.2
: P2 minor
Target Milestone: 3.4.5
Assignee: Volker Reichelt
URL: http://gcc.gnu.org/ml/gcc-patches/200...
Keywords: diagnostic
Depends on: 23586
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-10 17:18 UTC by Boris Kolpackov
Modified: 2005-09-01 11:33 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-04-11 06:10:58


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Kolpackov 2003-12-10 17:18:33 UTC
$ cat > test.cpp
namespace N1
{
  namespace N2
  {
  }
}

namespace N2
{
}

using namespace N1;
using namespace N2;

$ g++ --version
g++ (GCC) 3.3.2 (Debian)
$ g++ -c test.cpp
test.cpp:13: error: `<type error>' is not a namespace
$
Comment 1 Andrew Pinski 2003-12-10 17:44:06 UTC
Related to bug 12272.
Confirmed.
The error message on the mainline:
pr13377.cc:13: error: expected namespace-name
pr13377.cc:13: error: `<type error>' is not a namespace
Comment 2 Volker Reichelt 2005-08-29 13:32:50 UTC
Testing a patch.
Comment 3 CVS Commits 2005-08-31 10:33:08 UTC
Subject: Bug 13377

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	reichelt@gcc.gnu.org	2005-08-31 10:32:54

Modified files:
	gcc/cp         : ChangeLog parser.c 
	gcc/testsuite  : ChangeLog 
	gcc/testsuite/g++.dg/tc1: dr101.C 
Added files:
	gcc/testsuite/g++.dg/lookup: ambig4.C ambig5.C 

Log message:
	PR c++/13377
	* parser.c (cp_parser_lookup_name): Pass LOOKUP_COMPLAIN to
	lookup_name_real on final parse.
	
	* g++.dg/lookup/ambig4.C: New test.
	* g++.dg/lookup/ambig5.C: New test.
	* g++.dg/tc1/dr101.C: Adjust error markers.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/ChangeLog.diff?cvsroot=gcc&r1=1.4864&r2=1.4865
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/parser.c.diff?cvsroot=gcc&r1=1.352&r2=1.353
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.5985&r2=1.5986
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.dg/lookup/ambig4.C.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.dg/lookup/ambig5.C.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.dg/tc1/dr101.C.diff?cvsroot=gcc&r1=1.2&r2=1.3

Comment 5 Volker Reichelt 2005-08-31 11:07:38 UTC
For the testcase

  ==================================
  namespace N
  {
    int i;
  }

  int i;

  using namespace N;

  void foo() { i; }
  ==================================

we now get

  ambig4.C: In function 'void foo()':
  ambig4.C:10: error: use of 'i' is ambiguous
  ambig4.C:6: error:   first declared as 'int i' here
  ambig4.C:3: error:   also declared as 'int N::i' here
  ambig4.C:10: error: 'i' was not declared in this scope

Btw, this is the testcase which was a regression from GCC 3.3.x.

For the testcase

  ==================================
  namespace N
  {
    namespace M {}
  }

  namespace M {}

  using namespace N;
  using namespace M;
  ==================================

we now get (since the patch for PR23586 is also in place):

  ambig5.C:13: error: use of 'M' is ambiguous
  ambig5.C:10: error:   first declared as 'namespace M { }' here
  ambig5.C:7: error:   also declared as 'namespace M { }' here
  ambig5.C:13: error: 'M' is not a namespace-name
  ambig5.C:13: error: expected namespace-name before ';' token

This is still a little suboptimal (first we say it's ambiguous,
then we say it's not declared/not a namespace-name), but I think
the user can figure out the problem now.

So this is fixed on mainline and the 4.0 branch.
Comment 7 Volker Reichelt 2005-09-01 11:33:50 UTC
Fixed on the 3.4 branch, too.