Bug 13343 - [tree-ssa] self-pointing pointers are sometimes miscompiled
Summary: [tree-ssa] self-pointing pointers are sometimes miscompiled
Status: RESOLVED DUPLICATE of bug 21920
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: tree-ssa
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-07 18:37 UTC by James A. Morrison
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: sparc-unknown-linux-gnu
Target: sparc-unknown-linux-gnu
Build: sparc-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
testcase for self-pointing pointer (115 bytes, text/plain)
2003-12-07 18:39 UTC, James A. Morrison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James A. Morrison 2003-12-07 18:37:28 UTC
In the attached testcase v3 points to itself and is then assigned the value 123.
However, foo gets inlined at the rtl level in O1 or at the tree level in O2 and
causes the return value to be 20, on my machine, instead of 123 as is expected and
is returned on gcc 3.3 with and without optimizations.
Comment 1 James A. Morrison 2003-12-07 18:39:05 UTC
Created attachment 5294 [details]
testcase for self-pointing pointer
Comment 2 Falk Hueffner 2003-12-07 19:18:37 UTC
This is an aliasing violation; your test case is invalid.
Comment 3 Andrew Pinski 2005-06-05 08:31:44 UTC
Reopening to ...
Comment 4 Andrew Pinski 2005-06-05 08:31:59 UTC
Mark as a dup of bug 21920

*** This bug has been marked as a duplicate of 21920 ***