Bug 13253 - ICE when using DIMENSION and CHARACTER
Summary: ICE when using DIMENSION and CHARACTER
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: tree-ssa
: P3 enhancement
Target Milestone: tree-ssa
Assignee: Paul Brook
URL:
Keywords: ice-on-valid-code
: 12842 13280 13569 (view as bug list)
Depends on:
Blocks: 14082
  Show dependency treegraph
 
Reported: 2003-12-01 02:44 UTC by Dan Nicolaescu
Modified: 2004-06-16 13:51 UTC (History)
6 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2004-01-25 17:56:57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Nicolaescu 2003-12-01 02:44:07 UTC
With: gcc version 3.5-tree-ssa 20031130 (merged 20031123)

test.f90:

MODULE mymod
  TYPE :: MYTYPE
     CHARACTER(12),  DIMENSION(3) :: FIELD
  END TYPE MYTYPE
  TYPE (MYTYPE) :: MYVALUE
END MODULE mymod

SUBROUTINE MYSUB (MYARG)
  USE mymod;
END SUBROUTINE MYSUB


gfortran -c test.f90       
test.f90:0: internal compiler error: in gfc_get_dtype_cst, at
fortran/trans-types.c:585
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

If "DIMENSION(3)" is deleted,the code compiles fine.

Intel's compiler compiles the above code.

Code like this appears in SPEC2000
Comment 1 Paul Brook 2003-12-01 20:57:23 UTC
Arrays of character variables are not yet implemented. 
Comment 2 Andrew Pinski 2004-01-05 19:00:23 UTC
*** Bug 13280 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Pinski 2004-01-05 19:00:40 UTC
*** Bug 13569 has been marked as a duplicate of this bug. ***
Comment 4 Paul Brook 2004-01-20 15:47:12 UTC
*** Bug 12842 has been marked as a duplicate of this bug. ***
Comment 5 Victor Leikehman 2004-01-22 06:57:29 UTC
(In reply to comment #4)
> *** Bug 12842 has been marked as a duplicate of this bug. ***
13253 is marked as "low priority enhancement" now.  Let me
disagree -- since it prevents compiling 2 out of 4 SPEC2000
FP programs its priority should be no lower than that of the
other bugs.
Comment 6 Paul Brook 2004-04-04 23:33:44 UTC
Fixed.