Bug 13068 - [3.3 Regression] mklibgcc.in doesn't install deep MULTLIBS
Summary: [3.3 Regression] mklibgcc.in doesn't install deep MULTLIBS
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.3.2
: P2 normal
Target Milestone: 3.3.3
Assignee: Andrew Pinski
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2003-11-16 10:06 UTC by corsepiu
Modified: 2003-12-24 22:43 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-11-18 09:32:08


Attachments
Replacing mkdir with mkinstalldir (281 bytes, patch)
2003-11-16 10:09 UTC, corsepiu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description corsepiu 2003-11-16 10:06:06 UTC
mklibgcc.in uses mkdir to create multilib subdirs.
This fails on targets with deep multlib-subdirs, when no multilib variant in a
parent multilib subdir exists.

E.g. target=sh-rtems:
libgcc.a
ml/m2/libgcc.a
..
Note no ml/libgcc.a

This isse seems to be fixed in gcc-3.4/CVS-HEAD, but is present on
gcc-3_3-branch and affects sh-rtems* targets.

For these targets, this is a regression against gcc-3.2.x which did not expose
this issue.
Comment 1 corsepiu 2003-11-16 10:09:27 UTC
Created attachment 5148 [details]
Replacing mkdir with mkinstalldir
Comment 2 Andrew Pinski 2003-11-18 06:05:31 UTC
Can you send the patch to gcc-patches@gcc.gnu.org.
Comment 3 Andrew Pinski 2003-11-18 09:32:07 UTC
Patch here: <http://gcc.gnu.org/ml/gcc-patches/2003-11/msg01395.html>.
Comment 4 Andrew Pinski 2003-12-23 09:35:32 UTC
Gaby could you look at the patch here for approval, it is basically a backport of this patch: 
<http://gcc.gnu.org/ml/gcc-patches/2003-05/msg00630.html>.
Comment 5 Gabriel Dos Reis 2003-12-24 21:57:25 UTC
The patch is OK with all the corrections that ensued.

-- Gaby
Comment 6 Andrew Pinski 2003-12-24 22:25:52 UTC
I will commit it with all of the followups which are needed.
Comment 7 CVS Commits 2003-12-24 22:42:36 UTC
Subject: Bug 13068

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	pinskia@gcc.gnu.org	2003-12-24 22:42:33

Modified files:
	gcc            : ChangeLog mklibgcc.in 

Log message:
	2003-12-24  Andrew Pinski  <pinskia@physics.uc.edu>
	
	PR bootstrap/13068
	Backport from mainline:
	2003-05-09  Matt Kraai <kraai@alumni.cmu.edu>
	
	* mklibgcc.in: Remove extra quotes.
	2003-05-08  Aldy Hernandez  <aldyh@redhat.com>
	
	* mklibgcc.in: Use mkinstalldirs when installing multilib
	directories.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.16114.2.861&r2=1.16114.2.862
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/mklibgcc.in.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.48.4.4&r2=1.48.4.5

Comment 8 Andrew Pinski 2003-12-24 22:43:54 UTC
Fixed for 3.3.3.