Bug 12890 - [3.3 Regression] ICE on compilation of class with throwing method
Summary: [3.3 Regression] ICE on compilation of class with throwing method
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 3.3.1
: P2 normal
Target Milestone: 3.3.4
Assignee: Andrew Haley
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-11-03 20:17 UTC by gcc-bug
Modified: 2004-02-26 16:28 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2003-11-11 16:29:09


Attachments
M.java (70 bytes, text/plain)
2003-11-03 20:20 UTC, gcc-bug
Details
E.java (45 bytes, text/plain)
2003-11-03 20:21 UTC, gcc-bug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gcc-bug 2003-11-03 20:17:03 UTC
to reproduce:

(1) put files M.java and E.java in cwd
(2) execute gcj M.java

I get:
   M.java:0: internal compiler error: Segmentation fault
   Please submit a full bug report,
   with preprocessed source if appropriate.
   See <URL:http://gcc.gnu.org/bugs.html> for instructions.

Error show up with GCC 3.3, does not show up with GCC 3.2.2

==> M.java START <==
import E;

public class M {
        void fun (M q) throws E
        {
        }
};
==> M.java END <==
==> E.java START <==
public class E extends Throwable {
}
==> E.java END <==
Comment 1 gcc-bug 2003-11-03 20:20:46 UTC
Created attachment 5048 [details]
M.java
Comment 2 gcc-bug 2003-11-03 20:21:12 UTC
Created attachment 5049 [details]
E.java
Comment 3 Joe Buck 2003-11-04 01:21:36 UTC
Confirmed; it is also in 3.3.2 on i686-pc-linux-gnu.
Comment 4 CVS Commits 2003-11-12 15:24:46 UTC
Subject: Bug 12890

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	aph@gcc.gnu.org	2003-11-12 15:24:42

Modified files:
	gcc/java       : ChangeLog lang.c parse.y 

Log message:
	2003-11-12  Andrew Haley  <aph@redhat.com>
	
	PR java/11533
	* lang.c (merge_init_test_initialization): Clear DECL_INITIAL for
	init_test_decls being inlined.
	
	PR java/12890:
	* parse.y (do_resolve_class): Check return value from
	breakdown_qualified().

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/ChangeLog.diff?cvsroot=gcc&r1=1.1287&r2=1.1288
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/lang.c.diff?cvsroot=gcc&r1=1.145&r2=1.146
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/parse.y.diff?cvsroot=gcc&r1=1.453&r2=1.454

Comment 5 Andrew Haley 2003-11-12 15:25:53 UTC
Comments?  Pah!
Comment 6 gcc-bug 2004-02-26 06:14:35 UTC
just checked 3.3.3: Got the same error.
Comment 7 Dara Hazeghi 2004-02-26 06:37:19 UTC
Yeah, looks like Andrew didn't check his fix in on the branch...
Comment 8 CVS Commits 2004-02-26 11:14:04 UTC
Subject: Bug 12890

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	aph@gcc.gnu.org	2004-02-26 11:13:58

Modified files:
	gcc/java       : ChangeLog parse.y 

Log message:
	2004-02-26  Andrew Haley  <aph@redhat.com>
	
	PR java/12890:
	* parse.y (do_resolve_class): Check return value from
	breakdown_qualified().

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.1093.2.46&r2=1.1093.2.47
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/parse.y.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.405.2.10&r2=1.405.2.11

Comment 9 Andrew Haley 2004-02-26 11:14:47 UTC
Subject:  [3.3 Regression] ICE on compilation of class with throwing method

dhazeghi at yahoo dot com writes:
 > 
 > ------- Additional Comments From dhazeghi at yahoo dot com  2004-02-26 06:37 -------
 > Yeah, looks like Andrew didn't check his fix in on the branch...

Sorry about that.

Andrew.
Comment 10 Andrew Haley 2004-02-26 13:59:48 UTC
.