Bug 12848 - size of char... configure: error
Summary: size of char... configure: error
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.2
: P2 normal
Target Milestone: 3.3
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-30 21:53 UTC by Claudio Wahnschaffe
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Wahnschaffe 2003-10-30 21:53:47 UTC
I'm installing gcc 3.2 on an IBM Mainframe. I have binutils 2.12.90.0.15 with 
the patch for s390 downloaded from IBM, glibc 2.2.5 and kernel 2.2.16.

I have created a target directory for gcc and when I run 'configure' on it I 
receive the following messages:

Configuring fastjar...
loading cache ../config.cache
checking for a BSD compatible install... (cached) /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -g -O2 ) works... yes
checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... yes
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for a BSD compatible install... /usr/bin/ginstall -c
checking for rm... /bin/rm
checking for cp... /bin/cp
checking for strip... /usr/local/bin/strip
checking for chmod... /bin/chmod
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for executable suffix... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking how to run the C preprocessor... (cached) gcc -E
checking for ANSI C header files... (cached) no
checking whether struct tm is in sys/time.h or time.h... time.h
checking for fcntl.h... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/param.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for off_t... (cached) yes
checking whether struct tm is in sys/time.h or time.h... (cached) time.h
checking size of char... configure: error: can not run test program while cross 
compiling
Configure in /mnt/dasdc/gcc-3.2-obj/fastjar failed, exiting.

I made the configure with the option --disable-nls.

Could You help me please?

Thanks in advance, CLaudio.
Comment 1 Andrew Pinski 2003-10-31 00:43:46 UTC
Did you just configure or did you pass it something?
Comment 2 Claudio Wahnschaffe 2003-10-31 12:10:49 UTC
Subject: Re:  size of char... configure: error



I don't understand Your question.


Comment 3 Andrew Pinski 2003-11-02 23:02:25 UTC
How did you invoke configure?
Comment 4 Claudio Wahnschaffe 2003-11-03 14:39:46 UTC
Subject: Re:  size of char... configure: error



From target directory with --disable-nls.


Comment 5 Dara Hazeghi 2003-11-05 00:41:41 UTC
Bizarre... Can you attach /mnt/dasdc/gcc-3.2-obj/fastjar/config.log? Also what does ./
config.guess output? It seems to think its cross-compiling even though it shouldn't be.
Comment 6 Andrew Pinski 2003-11-05 00:49:30 UTC
Also can you try to build 3.3.2 as 3.2.x is no longer being updated?
Comment 7 Claudio Wahnschaffe 2003-11-05 16:31:34 UTC
Subject: Re:  size of char... configure: error



I made the following:

I reversed the upgrade of binutils (I have now binutils 2.9.1). Then I copied
the source of binutils 2.12.90.0.15 to the top level GCC 3.2 source tree before
configuring. After that I created a target directory and I executed 'configure
--disable-nls' on it. The configure ended now OK, but the 'make bootstrap' ended
now with the following error message:

make[3]: Entering directory `/mnt/dasdc/gcc-3.2-obj/gcc'
for d in libgcc; do \
  if [ -d $d ]; then true; else /bin/sh /mnt/dasdc/gcc-3.2/gcc/mkinstalldirs $d;
 fi; \
done
if [ -f stmp-dirs ]; then true; else touch stmp-dirs; fi
./xgcc -B./ -B/usr/local/s390-ibm-linux/bin/ -isystem
/usr/local/s390-ibm-linux/include -isystem /usr/local/s390-ibm-linux/sys-include
 -O2  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -isystem ./include  -fPIC -include
/mnt/dasdc/gcc-3.2/gcc/config/s390/fixdfdi.h -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2
 -D__GCC_FLOAT_NOT_NEEDED  -shared -nodefaultlibs -Wl,--soname=libgcc_s.so.1
-Wl,--version-script=libgcc/./libgcc.map -o libgcc_s.so.1   libgcc/./_muldi3.o
libgcc/./_negdi2.o libgcc/./_lshrdi3.o libgcc/./_ashldi3.o libgcc/./_ashrdi3.o
libgcc/./_ffsdi2.o libgcc/./_clz.o libgcc/./_cmpdi2.o libgcc/./_ucmpdi2.o
libgcc/./_floatdidf.o libgcc/./_floatdisf.o libgcc/./_fixunsdfsi.o
libgcc/./_fixunssfsi.o libgcc/./_fixunsdfdi.o libgcc/./_fixdfdi.o
libgcc/./_fixunssfdi.o libgcc/./_fixsfdi.o libgcc/./_fixxfdi.o
libgcc/./_fixunsxfdi.o libgcc/./_floatdixf.o libgcc/./_fixunsxfsi.o
libgcc/./_fixtfdi.o libgcc/./_fixunstfdi.o libgcc/./_floatditf.o
libgcc/./_clear_cache.o libgcc/./_trampoline.o libgcc
/./__main.o libgcc/./_exit.o libgcc/./_absvsi2.o libgcc/./_absvdi2.o
libgcc/./_addvsi3.o libgcc/./_addvdi3.o libgcc/./_subvsi3.o libgcc/./_subvdi3.o
libgcc/./_mulvsi3.o libgcc/./_mulvdi3.o libgcc/./_negvsi2.o libgcc/./_negvdi2.o
libgcc/./_ctors.o libgcc/./_divdi3.o libgcc/./_moddi3.o libgcc/./_udivdi3.o
libgcc/./_umoddi3.o libgcc/./_udiv_w_sdiv.o libgcc/./_udivmoddi4.o
libgcc/./unwind-dw2.o libgcc/./unwind-dw2-fde-glibc.o libgcc/./unwind-sjlj.o -lc
 && rm -f libgcc_s.so && ln -s libgcc_s.so.1 libgcc_s.so
/usr/local/s390-ibm-linux/bin/ld:libgcc/./libgcc.map:4: parse error in VERSION
script
collect2: ld returned 1 exit status
make[3]: *** [libgcc_s.so] Error 1
make[3]: Leaving directory `/mnt/dasdc/gcc-3.2-obj/gcc'
make[2]: *** [libgcc.a] Error 2
make[2]: Leaving directory `/mnt/dasdc/gcc-3.2-obj/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/mnt/dasdc/gcc-3.2-obj/gcc'
make: *** [bootstrap-lean] Error 2


Comment 8 Claudio Wahnschaffe 2003-11-05 20:14:23 UTC
Subject: Re:  size of char... configure: error



OK, I'll try to build gcc 3.3 with binutils 2.14.90.0.4 with the patches
recommended by IBM in
http://www10.software.ibm.com/developerworks/opensource/linux390/index.shtml


Comment 9 Claudio Wahnschaffe 2003-11-06 12:10:35 UTC
Subject: Re:  size of char... configure: error



I made the same for gcc 3.3. I copied binutils (2.14.90.0.4) to the top level of
gcc source directory, I made a target directory, then I executed 'configure
--disable-nls' on it. Configure ended OK.

Then I executed 'make bootstrap-lean' and it ended with the following message:

/bin/sh /mnt/dasdc/gcc-3.3/gcc/mkconfig.sh tconfig.h
./xgcc -B./ -B/usr/local/s390-ibm-linux/bin/ -isystem
/usr/local/s390-ibm-linux/include -isystem /usr/local/s390-ibm-linux/sys-include
 -O2 -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -isystem ./include  -I. -I. -I/mnt/dasdc/gcc-3.3/gcc
-I/mnt/dasdc/gcc-3.3/gcc/. -I/mnt/dasdc/gcc-3.3/gcc/config
-I/mnt/dasdc/gcc-3.3/gcc/../include  -g0 -finhibit-size-directive
-fno-inline-functions -fno-exceptions -fno-zero-initialized-in-bss
-fno-asynchronous-unwind-tables \
   -c /mnt/dasdc/gcc-3.3/gcc/crtstuff.c -DCRT_BEGIN \
  -o crtbegin.o
Assembler messages:
Error: invalid switch -m31
make[2]: *** [crtbegin.o] Error 1
make[2]: Leaving directory `/mnt/dasdc/gcc-3.3-obj/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/mnt/dasdc/gcc-3.3-obj/gcc'
make: *** [bootstrap-lean] Error 2


Comment 10 Andrew Pinski 2003-11-06 15:50:34 UTC
I think you have to build (and install)  binutils before you build gcc see bug 11321, now since that 
is the issue, I am closing this as fixed for 3.3.
Comment 11 Andrew Pinski 2003-11-06 15:50:42 UTC
I think you have to build (and install)  binutils before you build gcc see bug 11321, now since that 
is the issue, I am closing this as fixed for 3.3.