Bug 12842 - arrays of chars
Summary: arrays of chars
Status: RESOLVED DUPLICATE of bug 13253
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: tree-ssa
: P2 normal
Target Milestone: tree-ssa
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code, rejects-valid
Depends on:
Blocks:
 
Reported: 2003-10-30 12:32 UTC by Joost VandeVondele
Modified: 2004-06-16 13:51 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-12-16 23:39:40


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joost VandeVondele 2003-10-30 12:32:20 UTC
the following should compile :

   CHARACTER(LEN=1), PARAMETER, DIMENSION(0:1) :: l_sym = (/"s","p"/)
   write(6,*) l_sym(1)
   END
Comment 1 Paul Brook 2003-11-01 22:20:16 UTC
Arrays of character strings are not implemented yet. 
Comment 2 Paul Brook 2004-01-20 15:45:12 UTC

*** This bug has been marked as a duplicate of 13252 ***
Comment 3 Paul Brook 2004-01-20 15:46:20 UTC
Marked as duplicate of wrong bug. 
Comment 4 Paul Brook 2004-01-20 15:47:12 UTC

*** This bug has been marked as a duplicate of 13253 ***