User account creation filtered due to spam.

Bug 12821 - dead link on onlinedocs/gccint/Top-Level.html
Summary: dead link on onlinedocs/gccint/Top-Level.html
Status: NEW
Alias: None
Product: gcc
Classification: Unclassified
Component: web (show other bugs)
Version: 3.4.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: documentation
Depends on:
Blocks:
 
Reported: 2003-10-29 08:43 UTC by Joost VandeVondele
Modified: 2013-01-21 11:14 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2013-01-21 19:34:48


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joost VandeVondele 2003-10-29 08:43:21 UTC
On page 
http://gcc.gnu.org/onlinedocs/gccint/Top-Level.html
there is a link
"GNU configure and build system"
pointing to 
http://gcc.gnu.org/onlinedocs/configure/index.html
which can not be found
Comment 1 Andrew Pinski 2003-10-30 05:08:23 UTC
Since this file is generated from sourcebuild.texi, this is not a web problem but a documentation 
problem.
Comment 2 Joseph S. Myers 2003-10-30 10:11:58 UTC
Subject: Re:  dead link on onlinedocs/gccint/Top-Level.html

On Thu, 30 Oct 2003, pinskia at gcc dot gnu dot org wrote:

> Since this file is generated from sourcebuild.texi, this is not a web
> problem but a documentation problem.

No, it's a web problem.  Texinfo manuals can legitimately use Texinfo
links to other manuals in the Texinfo universe, not just those in GCC.  
We should find online copies (generated with makeinfo --html, one page per
node) of the manuals linked to (if necessary get the relevant project
maintainers - in this case GNU binutils - to put them up) and have
appropriate redirects in onlinedocs.

Comment 3 Joost VandeVondele 2006-06-12 07:18:42 UTC
(In reply to comment #0)

still failing ... since it has been opened about 2.5y ago, should it be closed as wontfix ?
Comment 4 Joost VandeVondele 2008-12-08 19:34:48 UTC
                                 |
                               \ ' /
                             -- (*) --
                                >*<
                               >0<@<
                              >>>@<<*
                             >@>*<0<<<
                            >*>>@<<<@<<
                           >@>>0<<<*<<@<
                          >*>>0<<@<<<@<<<
                         >@>>*<<@<>*<<0<*<
           \*/          >0>>*<<@<>0><<*<@<<
       ___\\U//___     >*>>@><0<<*>>@><*<0<<
       |\\ | | \\|    >@>>0<*<0>>@<<0<<<*<@<<  
       | \\| | _(UU)_ >((*))_>0><*<0><@<<<0<*<
       |\ \| || / //||.*.*.*.|>>@<<*<<@>><0<<<
  jgs  |\\_|_|&&_// ||*.*.*.*|_\\db//_               
       """"|'.'.'.|~~|.*.*.*|     ____|_
           |'.'.'.|   ^^^^^^|____|>>>>>>|
           ~~~~~~~~         '""""`------'

 
5 years later ... adding a Christmas tree to the bug report.
Comment 5 Steven Bosscher 2008-12-08 20:20:38 UTC
Joseph Myers introduced this in the manual with the following patch:
http://gcc.gnu.org/ml/gcc-patches/2002-01/msg00726.html

So this is a regression.

Ah, and Joseph also explained how to fix this, see comment #2.  So this should be fixed in the blink of an eye then, no?
Comment 6 Joseph S. Myers 2008-12-08 20:29:38 UTC
As I explained in 2003, this is a web problem, not a source code bug, and so not a regression.  It is a new feature of the manual such that each user of the manual may need to do something to take advantage of the new feature, and that applies to the onlinedocs on gcc.gnu.org just as it does to any user of "make install-html".
Comment 7 Steven Bosscher 2008-12-08 20:40:05 UTC
Well, I can't even find this paragraph you want to reference.

And I was under the impression that there was a kind-of "you broke it, you fix it rule" with GCC bugs.  Am I wrong or does this just not apply to you?
Comment 8 joseph@codesourcery.com 2008-12-08 21:00:22 UTC
Subject: Re:  dead link on onlinedocs/gccint/Top-Level.html

On Mon, 8 Dec 2008, steven at gcc dot gnu dot org wrote:

> Well, I can't even find this paragraph you want to reference.

The reference is to a whole manual (etc/configure.texi in the src 
repository), not to one paragraph.

> And I was under the impression that there was a kind-of "you broke it, you fix
> it rule" with GCC bugs.  Am I wrong or does this just not apply to you?

There is no such rule beyond the limited reversion rule in develop.html.

As explained, this is a missing website feature, not a GCC bug.  The link 
in the manual is a correct link in the global namespace for Texinfo 
manuals.

Comment 9 Steven Bosscher 2008-12-09 09:00:43 UTC
Something as simple as this would already fix the broken link.

Index: gcc/doc/sourcebuild.texi
===================================================================
--- gcc/doc/sourcebuild.texi    (revision 142582)
+++ gcc/doc/sourcebuild.texi    (working copy)
@@ -93,8 +93,14 @@
 The build system in the top level directory, including how recursion
 into subdirectories works and how building runtime libraries for
 multilibs is handled, is documented in a separate manual, included
-with GNU Binutils.  @xref{Top, , GNU configure and build system,
+with GNU Binutils.
+@c ??? This manual is apparently not available online.  Keep the cross
+@c reference for 'info' but leave it out of HTML pages to avoid broken
+@c links on the web site.
+@ifinfo
+@xref{Top, , GNU configure and build system,
 configure, The GNU configure and build system}, for details.
+@end ifinfo

 @node gcc Directory
 @section The @file{gcc} Subdirectory
Comment 10 joseph@codesourcery.com 2008-12-09 13:40:24 UTC
Subject: Re:  dead link on onlinedocs/gccint/Top-Level.html

On Tue, 9 Dec 2008, steven at gcc dot gnu dot org wrote:

> +@c ??? This manual is apparently not available online.  Keep the cross

But it is online - http://www.airs.com/ian/configure/ - and while that's 
not a makeinfo --html copy, when it's only linking to the manual as a 
whole that doesn't matter much (a single redirect in .htaccess should 
suffice - and the fix being such a redirect is why I say this is a web 
problem not a manual problem).

I believe the description of how multilibs are built is still relevant, 
although no-one has updated that manual to reflect toplevel 
autoconfiscation.  If the assignment issues were resolved (that manual has 
a Cygnus copyright notice) then it might make sense to move the multilib 
documentation into the GCC documentation and remove the reference to this 
old manual.

Comment 11 Joost VandeVondele 2013-01-21 08:07:20 UTC
CLOSE WONTFIX ?
Comment 12 Manuel López-Ibáñez 2013-01-21 11:03:38 UTC
(In reply to comment #11)
> CLOSE WONTFIX ?

No, there are several possible fixes:

* A patch to .htaccess to redirect to Ian's webpage as suggested in comment #5. See http://gcc.gnu.org/cvs.html and http://gcc.gnu.org/contribute.html#webchanges

* Contact Ian Lance Taylor, figure out the copyright issues to move the manual to the GCC repository, and if they cannot be solved, create a new manual from scratch. 

The problem is not that the bug cannot be or is not desired to be solved. The problem is that no one is not sufficiently interested on solving it to spent the time and effort required. If you are, please do it!
Comment 13 Manuel López-Ibáñez 2013-01-21 11:14:43 UTC
In fact, the nicest solution would be to investigate how much of Ian's document is already duplicated in the GNU binutils sources:

http://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/

and move any GCC-specific parts (e.g., multilibs) directly to the GCC internal documentation.

Of course, this requires *new people* to do it, it is clearly not a priority for the existing devs.