Bug 12650 - [tree-ssa] ICE in tree-flow-inline.h with "-O -fssa" but not with "-O"
Summary: [tree-ssa] ICE in tree-flow-inline.h with "-O -fssa" but not with "-O"
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: tree-ssa
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 12652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-10-16 20:48 UTC by Steven Bosscher
Modified: 2003-11-26 02:09 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-10-19 07:09:37


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Bosscher 2003-10-16 20:48:27 UTC
The following:

void
foo (void)
{
  goto loop_entry;
loop_start:
loop_entry:
  goto loop_start;
loop_exit:
}

compiles with just "-O" but segfaults with "-O -fssa"

Normally I wouldn't give a s... about -fssa, but:
a) this test case was deduced from gcc.dg/20020304-1.c which
   also ICEs on the tree-ssa branch on a sanity check after
   -fssa-ccp.  This new ICE might be related, perhaps we just
   compute broken dominance information for RTL???
b) this ICE happens in tree-flow-inline.h according to gdb:

Program received signal SIGSEGV, Segmentation fault.
compute_dominance_frontiers_1 (frontiers=0x8627520, idom=0x8627610, bb=0,
    done=0x86275f8) at tree-flow-inline.h:270
270     tree-flow-inline.h: No such file or directory.
        in tree-flow-inline.h

    Weird to have a tree-ssa failure with RTL SSA, but in tree-ssa code!
Comment 1 Andrew Pinski 2003-10-16 22:20:03 UTC
*** Bug 12652 has been marked as a duplicate of this bug. ***
Comment 2 Diego Novillo 2003-10-16 22:42:30 UTC
Subject: Re:  New: [tree-ssa] ICE in tree-flow-inline.h with
	"-O -fssa" but not with "-O"

On Thu, 2003-10-16 at 16:48, steven at gcc dot gnu dot org wrote:

>     Weird to have a tree-ssa failure with RTL SSA, but in tree-ssa code!
> 
Parts of the common code that used to exist in RTL SSA has been moved
into the tree-* files to make it easier to remove the RTL SSA stuff at a
later date.


Diego.

Comment 3 Steven Bosscher 2003-10-16 22:44:43 UTC
Subject: Re:  [tree-ssa] ICE in tree-flow-inline.h with "-O
	-fssa" but not with "-O"

Op vr 17-10-2003, om 00:42 schreef dnovillo at redhat dot com:
> Parts of the common code that used to exist in RTL SSA has been moved
> into the tree-* files to make it easier to remove the RTL SSA stuff at a
> later date.

So the decision has been made and RTL SSA is going to be wiped away?  We
were just discussing this on IRC :)  I thought Jeff still had plans with
it??

Gr.
Steven

Comment 4 Diego Novillo 2003-10-16 22:48:40 UTC
Subject: Re:  [tree-ssa] ICE in tree-flow-inline.h with "-O
	-fssa" but not with "-O"

On Thu, 2003-10-16 at 18:44, steven at gcc dot gnu dot org wrote:

> So the decision has been made and RTL SSA is going to be wiped away?  We
> were just discussing this on IRC :)  I thought Jeff still had plans with
> it??
> 
Dunno.  I thought it was going to be removed, but I haven't been paying
much attention to that issue.


Diego.

Comment 5 Steven Bosscher 2003-10-16 23:44:33 UTC
OK then.  Let's XFAIL gcc.dg/20020304-1.c and close this report.
Comment 6 Andrew Pinski 2003-11-26 02:09:18 UTC
Closing as will not fix as -fssa has now been removed from the mainline and the tree-ssa.