Bug 12449 - [3.3 regression] ICE in add_abstract_origin_attribute
Summary: [3.3 regression] ICE in add_abstract_origin_attribute
Status: RESOLVED DUPLICATE of bug 11522
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 3.3.2
: P2 critical
Target Milestone: 3.3.2
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-09-29 21:50 UTC by Debian GCC Maintainers
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2003-09-29 21:50:11 UTC
[forwarded from http://bugs.debian.org/212406]

works with 2.95, 3.0.4, fails with 3.2.3, current 3.3.2, works with HEAD.
same behaviour on i486-linux and powerpc-linux

g77 -g -c -O3 -g  -fno-automatic -fno-second-underscore -fugly-complex ranget.f
ranget.f:1: Internal compiler error in add_abstract_origin_attribute, at
dwarf2out.c:9465
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

          SUBROUTINE RANGET(SEED)
          DOUBLE PRECISION    SEED,     G900GT,   G900ST,   DUMMY
          SEED  =  G900GT()
          RETURN
          ENTRY RANSET(SEED)
          DUMMY  =  G900ST(SEED)
          RETURN
          END
Comment 1 Andrew Pinski 2003-09-29 21:57:48 UTC
Most likely connected to bug 11522 and PR 9864.
Comment 2 Toon Moene 2003-10-01 19:49:23 UTC
This was fixed on the 11th of September 2003 by Alexandre Oliva
both on mainline and the 3.3 branch.

I just checked this with a freshly updated CVS checkout for the 3.3 branch.

Toon Moene
Comment 3 Toon Moene 2003-10-07 18:49:42 UTC
Reopen to ...
Comment 4 Toon Moene 2003-10-07 18:52:30 UTC
... to mark as duplicate of 11522.

*** This bug has been marked as a duplicate of 11522 ***