Bug 12182 - compilation of iText fails, probably a bug
Summary: compilation of iText fails, probably a bug
Status: NEW
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 3.4.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on:
Reported: 2003-09-05 11:58 UTC by Philip Chinery
Modified: 2005-07-23 22:39 UTC (History)
3 users (show)

See Also:
Known to work:
Known to fail:
Last reconfirmed: 2004-01-21 19:26:49

full source.... (618.63 KB, application/octet-stream)
2004-01-21 19:28 UTC, Dara Hazeghi

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Chinery 2003-09-05 11:58:08 UTC
When compiling iText 1.0.0 (with gcj 3.4 and 3.3.1 und windows/mingw) I get 
the following error:

D:\MinGW\classpath\lib_test\PdfCopy.java: In class 
D:\MinGW\classpath\lib_test\PdfCopy.java: In method 
D:\MinGW\classpath\lib_test\PdfCopy.java:170: error: Can't find constructor 
(Lcom/lowagie/text/pdf/PRIndirectReference;)' in type 
`com.lowagie.text.pdf.PdfCopy$RefKey'. Candidates are:  `
(com.lowagie.text.pdf.PdfCopy,com.lowagie.text.pdf.PdfIndirectReference)' in
  `(com.lowagie.text.pdf.PdfCopy,com.lowagie.text.pdf.PRIndirectReference)' in 
           RefKey key = new RefKey(in);

This could probably be a bug, because this works without errors with the JDK 
and also compiled with the Excelsior JET trial version.
I have assembled all files required for the project in a zip file, to 
reproduce it. It is 2.4 MB big, so I could mail it to anyone interested on 

I am calling gcj with this command line:
D:\mingw\bin\gcj.exe --classpath=D:\MinGW\classpath\rt --
D:\MinGW\classpath\lib_test\*.java -o d:\mingw\encryptpdf.exe
All files are placed in D:\MinGW\classpath\rt and subdirectories, but I also 
had to include all files seperately, because else I got undefined reference 
errors. So all files are placed in D:\MinGW\classpath\lib_test and included in 
a bulk.

Comment 1 Andrew Pinski 2003-09-05 15:02:46 UTC
Can you attach it, please it would be nice so if you cannot be found on the face of the earth.
Comment 2 Dara Hazeghi 2004-01-21 17:53:27 UTC
I found itext 1.00 (from itext.sf.net) and tried this out with gcc 3.3.1. It worked fine. Where did you 
get your sources for iText?
Comment 3 Dara Hazeghi 2004-01-21 19:26:48 UTC
Okay, reproduced. Someone with more knowledge should probably try to reduce it though.
Comment 4 Dara Hazeghi 2004-01-21 19:28:27 UTC
Created attachment 5546 [details]
full source....

uncompess, problem is with gcj -classpath=. -c -c
Comment 5 Bob Bell 2004-04-13 18:03:08 UTC
Any status on this?  I'd love to try out a patch or...