Bug 12042 - AltiVec array initializer: internal compiler error: Segmentation fault
Summary: AltiVec array initializer: internal compiler error: Segmentation fault
Status: RESOLVED DUPLICATE of bug 11949
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.3.1
: P2 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-24 00:06 UTC by James Klicman
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: powerpc-unknown-linux-gnu
Target: powerpc-unknown-linux-gnu
Build: powerpc-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Klicman 2003-08-24 00:06:46 UTC
#include <altivec.h>

static const vector signed short PostScale[8] = {
    (vector signed short){4095, 5681, 5351, 4816, 4095, 4816, 5351, 5681},
    (vector signed short){5681, 7880, 7422, 6680, 5681, 6680, 7422, 7880},
    (vector signed short){5351, 7422, 6992, 6292, 5351, 6292, 6992, 7422},
    (vector signed short){4816, 6680, 6292, 5663, 4816, 5663, 6292, 6680},
    (vector signed short){4095, 5681, 5351, 4816, 4095, 4816, 5351, 5681},
    (vector signed short){4816, 6680, 6292, 5663, 4816, 5663, 6292, 6680},
    (vector signed short){5351, 7422, 6992, 6292, 5351, 6292, 6992, 7422},
    (vector signed short){5681, 7880, 7422, 6680, 5681, 6680, 7422, 7880}
};


$ gcc -maltivec -mabi=altivec -c foo.c 
foo.c:12: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 1 Andrew Pinski 2003-08-24 00:11:38 UTC
This is a dup of bug 11949.

*** This bug has been marked as a duplicate of 11949 ***