Bug 12034 - [3.4 Regression] Objective-C linking problem
[3.4 Regression] Objective-C linking problem
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: libobjc
3.4.0
: P1 critical
: 3.4.0
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-22 20:19 UTC by Václav Zeman
Modified: 2004-01-17 04:22 UTC (History)
2 users (show)

See Also:
Host: i686-pc-cygwin
Target: i686-pc-cygwin
Build: i686-pc-cygwin
Known to work:
Known to fail:
Last reconfirmed: 2003-08-22 20:33:38


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Václav Zeman 2003-08-22 20:19:34 UTC
GCC can't find libobjc.a. It seems to be because it searches in
/usr/local/lib/gcc instead of /usr/local/lib/gcc-lib where libobjc is installed
by make install.

wilx@amber2 /C/WilX/objc
$ gcc-34 -v -o main.exe main.o List.o -lobjc
Reading specs from /usr/local/lib/gcc/i686-pc-cygwin/3.4/specs
Configured with: ../srcdir/configure --enable-threads=posix --enable-languages=c
,c++,objc --enable-dwarf2 --program-suffix=-34 --without-included-gettext --enab
le-version-specific-runtime-libs --enable-nls --with-arch=athlon --with-cpu=athl
on --disable-libstdcxx-pch --enable-intermodule --enable-objc-gc : (reconfigured
)
Thread model: posix
gcc version 3.4 20030821 (experimental)
 /usr/local/libexec/gcc/i686-pc-cygwin/3.4/collect2.exe -Bdynamic --dll-search-p
refix=cyg -o main.exe /lib/crt0.o -L/usr/local/lib/gcc/i686-pc-cygwin/3.4 -L/usr
/local/lib/gcc/i686-pc-cygwin/3.4/../../../../i686-pc-cygwin/lib -L/usr/local/li
b/gcc/i686-pc-cygwin/3.4/../../.. main.o List.o -lobjc -lgcc -lcygwin -luser32 -
lkernel32 -ladvapi32 -lshell32 -lgcc
/usr/local/lib/gcc/i686-pc-cygwin/3.4/../../../../i686-pc-cygwin/bin/ld: cannot
find -lobjc
collect2: ld returned 1 exit status
Comment 1 Andrew Pinski 2003-08-22 20:33:37 UTC
Fix is by patch in <http://gcc.gnu.org/ml/gcc-patches/2003-08/msg01357.html> but still needs 
a changelog.
Approved in <http://gcc.gnu.org/ml/gcc-patches/2003-08/msg01370.html>.
Comment 2 Andrew Pinski 2003-08-28 01:19:46 UTC
Fixed by the patch that was referenced above, the patch just went in.