Bug 11660 - libffi only builds when java is selected as language
Summary: libffi only builds when java is selected as language
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.3
: P2 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: build
Depends on:
Blocks:
 
Reported: 2003-07-24 12:24 UTC by dleeuw
Modified: 2016-09-15 20:46 UTC (History)
4 users (show)

See Also:
Host: i686-linux-gnu
Target: i686-linux-gnu
Build: i686-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2006-01-21 02:51:43


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dleeuw 2003-07-24 12:24:45 UTC
I don't know for sure if this is a bug or intended but trying to build gcc with
only c,c++,objc doesn't get met libffi. Enabling java also create libffi,
configure values:
configure --prefix=/usr/local/gcc-$DATE --enable-languages=c,c++,objc,java
--enable-shared --enable-threads=posix --enable-nls --with-gnu-as --with-gnu-ld
--without-included-gettext --with-system-zlib
--enable-version-specific-runtime-libs --enable-objc-gc --enable-clocale=gnu
--with-libffi

I just tested it with gcc 3.3. On a Debian testing system.
Comment 1 Andrew Pinski 2003-07-24 12:41:10 UTC
The only language that needs libffi for support of the programs in GCC is java, so it is only built 
when java is selected.  Maybe it can be built when --enable-libffi is done but it is not currently.  
Also libffi is updated from upstream so GCC are not the official maintainers so maybe this should 
be closed.
Comment 2 dennis@pruts.nl 2003-07-24 12:48:53 UTC
Subject: Re:  libffi only builds when java is selected
 as language

Objective-C or atleast GNUstep can also use libffi, so it is useful for
the GNUstep project.
Might it be useful to contact the upstream team for this, and if so who
should I contact for this.

Dennis

On 24 Jul 2003, pinskia at physics dot uc dot edu wrote:

> PLEASE REPLY TO gcc-bugzilla@gcc.gnu.org ONLY, *NOT* gcc-bugs@gcc.gnu.org.
>
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=11660
>
>
> pinskia at physics dot uc dot edu changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>            Severity|minor                       |enhancement
>              Status|UNCONFIRMED                 |NEW
>           Component|target                      |bootstrap
>      Ever Confirmed|                            |1
>    Last reconfirmed|0000-00-00 00:00:00         |2003-07-24 12:41:11
>                date|                            |
>
>
> ------- Additional Comments From pinskia at physics dot uc dot edu  2003-07-24 12:41 -------
> The only language that needs libffi for support of the programs in GCC is java, so it is only built
> when java is selected.  Maybe it can be built when --enable-libffi is done but it is not currently.
> Also libffi is updated from upstream so GCC are not the official maintainers so maybe this should
> be closed.
>
>
>
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>

Comment 3 Andrew Pinski 2003-07-24 12:57:28 UTC
Note GNUStep is not part of GCC.
Even though this page: <http://sources.redhat.com/libffi/> says it is largely maintained by GCC, it 
is wrong.
From libffi/README in the mainline of GCC:
This directory contains the libffi package, which is not part of GCC but
shipped with GCC as convenience.

So I think there is no upstream anymore, it looks like.
Comment 4 dennis@pruts.nl 2003-07-24 13:00:45 UTC
Subject: Re:  libffi only builds when java is selected
 as language



> ------- Additional Comments From pinskia at physics dot uc dot edu  2003-07-24 12:57 -------
> Note GNUStep is not part of GCC.
> Even though this page: <http://sources.redhat.com/libffi/> says it is largely maintained by GCC, it
> is wrong.

Okay, I counted on that being true :)
I'll will just use the libffi from Red Hat, and compile GCC without it.
Thanks!

Dennis

> >From libffi/README in the mainline of GCC:
> This directory contains the libffi package, which is not part of GCC but
> shipped with GCC as convenience.
>
> So I think there is no upstream anymore, it looks like.

Comment 5 Rainer Orth 2003-07-24 15:33:43 UTC
Subject: Re:  libffi only builds when java is selected as language

In fact, there's currently work in progress to make the GCC copy the master
version and merge any remaining changes from the sources.redhat.com
repository.  At that time it is certainly appropriate to be able to build
and install libffi even without java.

	Rainer
Comment 6 Andrew Pinski 2004-02-27 15:41:06 UTC
Mine as work to get libobjc "modernized" or remove the builtin_apply "hacks".
Comment 7 Alex Perez 2004-07-02 23:00:03 UTC
I would also like to throw my support behind this modification/enhancement. This
is important/necessary for more than just java. GNUstep can use either libffi or
ffcall, and libffi is preferable for a number of reasons, but as of now it's a
massive pain in the ass to build because you have to check out way more than you
actually need. So the entire GNUstep community would benefit from this
modificaitons, as well as numerous other communities, including the pyobjc
community. I would prefer an --enable-libffi configure option as Andrew Pinski
suggests.
Comment 8 Andrew Pinski 2004-12-12 04:32:03 UTC
This might get into 4.0.0 because __builtin_apply is so broken on most targets that fails for most tests 
already now on the mainline.

Patch here: <http://gcc.gnu.org/ml/gcc-patches/2004-12/msg00841.html>, just waiting for a global 
write maintainer to approve it.
Comment 9 Andrew Pinski 2005-04-21 16:42:32 UTC
The patch has to be updated.  I might do that this weekend.
Comment 10 Andrew Pinski 2005-10-23 00:08:53 UTC
No longer working on this.
Comment 11 Eric Gallager 2015-04-28 15:26:22 UTC
Doesn't libffi also get built if go is selected as a language? I can't verify it for myself due to bug 46986, but based on my reading of Makefile.def, it seems like building libgo should cause libffi to be built, as well...
Comment 12 Ian Lance Taylor 2016-09-15 20:46:43 UTC
I don't think there is anything to fix here, so I'm going to close this.  GCC is not the master source for libffi.