User account creation filtered due to spam.

Bug 11612 - abi_check not finding correct libgcc_s.so.1
Summary: abi_check not finding correct libgcc_s.so.1
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.3.1
: P2 normal
Target Milestone: 3.3.3
Assignee: Not yet assigned to anyone
URL:
Keywords: build
: 11626 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-21 04:04 UTC by gschafer
Modified: 2003-12-10 23:29 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-07-23 21:04:24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gschafer 2003-07-21 04:04:42 UTC
This is from the current 3.3 branch.

                === libstdc++-v3 Summary ===

# of expected passes            452
# of unexpected failures        1
# of unexpected successes       26
# of expected failures          2
make[4]: *** [check-DEJAGNU] Error 1
make[4]: Leaving directory
`/mnt/hdb7/gcc/branch-3.3/gcc-build/i686-pc-linux-gnu/libstdc++-v3/testsuite'
make[4]: Entering directory
`/mnt/hdb7/gcc/branch-3.3/gcc-build/i686-pc-linux-gnu/libstdc++-v3/testsuite'
Makefile:480: warning: overriding commands for target `check-am'
Makefile:396: warning: ignoring old commands for target `check-am'
./abi_check: /lib/libgcc_s.so.1: version `GCC_3.3' not found (required by
/mnt/hdb7/gcc/branch-3.3/gcc-build/i686-pc-linux-gnu/libstdc++-v3/s
rc/.libs/libstdc++.so.5)

It should be looking for the newly built libgcc_s.so.1 (not the one in /lib).
Looks like some LD_LIBRARY_PATH fine tuning is needed.

Thanks
Comment 1 Andrew Pinski 2003-07-23 21:04:24 UTC
Can happen any where, it happens when you compile but do not set 
LD_LIBRARY_PATH untill after compiling gcc/checking gcc.
Comment 2 Andrew Pinski 2003-07-23 21:04:53 UTC
*** Bug 11626 has been marked as a duplicate of this bug. ***
Comment 3 CVS Commits 2003-12-10 21:43:14 UTC
Subject: Bug 11612

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	bkoz@gcc.gnu.org	2003-12-10 21:43:10

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite: Makefile.am Makefile.in 

Log message:
	2003-12-10  Benjamin Kosnik  <bkoz@redhat.com>
	Alexandre Oliva  <aoliva@redhat.com>
	
	PR libstdc++/11612
	* testsuite/Makefile.am (GLIBCXX_DIR): New.
	(GLIBGCC_DIR): New.
	(CXXLINK): Use both with -R so libtool links the correct libs.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2150&r2=1.2151
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/Makefile.am.diff?cvsroot=gcc&r1=1.32&r2=1.33
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/Makefile.in.diff?cvsroot=gcc&r1=1.67&r2=1.68

Comment 4 CVS Commits 2003-12-10 21:54:00 UTC
Subject: Bug 11612

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	bkoz@gcc.gnu.org	2003-12-10 21:53:56

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite: Makefile.am Makefile.in 

Log message:
	2003-12-10  Benjamin Kosnik  <bkoz@redhat.com>
	Alexandre Oliva  <aoliva@redhat.com>
	
	PR libstdc++/11612
	* testsuite/Makefile.am (GLIBCXX_DIR): New.
	(GLIBGCC_DIR): New.
	(CXXLINK): Use both with -R so libtool links the correct libs.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.1464.2.159&r2=1.1464.2.160
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/Makefile.am.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.12.2.6&r2=1.12.2.7
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/Makefile.in.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.37.2.8&r2=1.37.2.9

Comment 5 Andrew Pinski 2003-12-10 23:29:37 UTC
Fixed for 3.3.3.