User account creation filtered due to spam.

Bug 11610 - testcases 27_io/* don't work properly remotely
Summary: testcases 27_io/* don't work properly remotely
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.3.1
: P2 normal
Target Milestone: 3.4.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 15047
  Show dependency treegraph
 
Reported: 2003-07-20 22:12 UTC by dank
Modified: 2004-05-30 15:13 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: sh4-*-linux-gnu,powerpc-*-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2004-01-27 02:33:24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dank 2003-07-20 22:12:23 UTC
I'm building and testing cross-compilers from gcc-3.3 and gcc-ss-3_3-20030714
using http://kegel.com/crosstool.
The libstdc++ test fails with

FAIL: 27_io/filebuf_members.cc execution test

rsh output is filebuf_members.exe.7466:
.../gcc-ss-3_3-20030714/libstdc++-v3/testsuite/27_io/filebuf_members.cc:62: void
test_01(): Assertion `fb_01.is_open()' failed.
XYZ134ZYX
Aborted
Comment 1 dank 2003-08-25 15:10:49 UTC
The regression tests

filebuf_members
filebuf_virtuals
ifstream_members
istream_extractor_other
istream_seeks
istream_unformatted
ostream_inserter_other

all fail because they assume the input files *.txt, *.tst
are available on the target.  (They also seem to create
output files in / on the target, but that might just be
a strangeness in my setup.)

The right fix would be to use dejagnu's remote file operations
to copy those files to the target when is_remote is true.
Comment 2 Benjamin Kosnik 2003-10-20 14:51:13 UTC
> The right fix would be to use dejagnu's remote file operations
> to copy those files to the target when is_remote is true.

Well, I think the framework tries to copy these files always. See
libstdc++-v3/testsuite/lib/libstdc++.exp

proc v3-init { args } {
...
    # Copy any required data files.
    v3-copy-files [glob -nocomplain "$srcdir/data/*.tst"] $outdir
    v3-copy-files [glob -nocomplain "$srcdir/data/*.txt"] $outdir
...
}

Where

# Called by v3-init below.  "Static" to this file.
proc v3-copy-files {srcfiles dstdir} {
    foreach f $srcfiles {
        if { [catch { set symlink [file readlink $f] } x] } then {
            file copy -force $f $dstdir
        } else {
            if { [regexp "^/" "$symlink"] } then {
                file copy -force $symlink $dstdir
            } else {
                set dirname [file dirname $f]
                file copy -force $dirname/$symlink $dstdir
            }
        }
    }
}

If there's a better way to do it, I'm interested in seeing the patch.

best,
benjamin
Comment 3 Benjamin Kosnik 2004-05-13 16:08:50 UTC
I'd like to close this: I think that 15047 fixes it. Please confirm.

-benjamin
Comment 4 Benjamin Kosnik 2004-05-23 17:21:00 UTC
Fixed in 3.4 and mainline.