Bug 11592 - [3.3 Regression] gcc.dg/duff-2.c fails with "warning: unreachable code at beginning of switch statement"
Summary: [3.3 Regression] gcc.dg/duff-2.c fails with "warning: unreachable code at beg...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 3.3
: P2 normal
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords: diagnostic
Depends on:
Blocks:
 
Reported: 2003-07-19 18:32 UTC by dank
Modified: 2003-09-17 22:07 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: powerpc-*-linux-gnu,sh4*-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2003-07-19 22:29:13


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dank 2003-07-19 18:32:12 UTC
I'm building and testing cross-compilers using http://kegel.com/crosstool

Both gcc-3.3 and gcc-ss-3_3-20030714's 'make check-gcc' produce
the following error:

FAIL: gcc.dg/duff-2.c (test for excess errors)
Excess errors:
/crosstool-0.13/build/powerpc-750-linux-gnu/gcc-3.3-glibc-2.2.5/gcc-3.3/gcc/testsuite/gcc.dg/duff-2.c:28:
warning: unreachable code at beginning of switch statement

This looks like PR 5230 but on a different platform.
I haven't tested an x86 compiler.
It also looks similar to PR 11370.
Comment 1 Andrew Pinski 2003-07-19 22:29:13 UTC
I can confirm this in 3.3.1 (20030714) but on the mainline (20030719), it is already fixed, 
this on powerpc-*linux-gnu, I have not checked with sh4-*-linux-gnu yet.
Comment 2 Andrew Pinski 2003-09-17 22:06:41 UTC
Since this is only a diagnostic problem closing as Mark is closing diagnostic problems.
Comment 3 Andrew Pinski 2003-09-17 22:07:10 UTC
I should have said which are already fixed on the mainline.