Bug 11359 - No bootstrap for cygwin using PCH: ICE creating bits/stdc++.h.gch/O2g
Summary: No bootstrap for cygwin using PCH: ICE creating bits/stdc++.h.gch/O2g
Status: RESOLVED DUPLICATE of bug 11360
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.4.0
: P2 critical
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-28 11:10 UTC by Christian Joensson
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i{6,7}86-pc-cygwin
Target: i{6,7}86-pc-cygwin
Build: i{6,7}86-pc-cygwin
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Joensson 2003-06-28 11:10:04 UTC
Windows XP/Pro SP1 cygwin P4 system with these packages:

binutils  2.13.90 20030308
bison     1.875-1
cygwin    1.3.22-1
dejagnu   1.4.2.x           (cygwin ver. 20021217-2)
gawk      3.1.2-3
gcc       3.2 20020927 (prerelease)
w32api    2.3-1

LAST_UPDATED: Sat Jun 28 08:24:30 GMT 2003

configure  pentium4-cygwin --prefix=/usr/local/gcc-binutils --enable-shared --
enable-threads=posix


touch ./pentium4-cygwin/bits/stdc++.h; \
if [ ! -d "./pentium4-cygwin/bits/stdc++.h.gch" ]; then \
  mkdir -p ./pentium4-cygwin/bits/stdc++.h.gch; \
fi; \
/usr/local/src/gcc-binutils/trunk/objdir/gcc/xgcc -shared-libgcc -
B/usr/local/src/gcc-binutils/trunk/objdir/gcc/ -nostdinc++  -
L/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-v3/src -
L/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/src/.libs -B/usr/local/gcc-binutils/pentium4-cygwin/bin/ -B/usr/local/gcc-
binutils/pentium4-cygwin/lib/ -isystem /usr/local/gcc-binutils/pentium4-
cygwin/include -isystem /usr/local/gcc-binutils/pentium4-cygwin/sys-include -
L/usr/local/src/gcc-binutils/trunk/objdir/ld -Winvalid-pch -Wno-deprecated -x 
c++-header -g -O2 -nostdinc++ -I/usr/local/src/gcc-
binutils/trunk/objdir/pentium4-cygwin/libstdc++-v3/include/pentium4-cygwin -
I/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include -I/usr/local/src/gcc-binutils/trunk/gcc-binutils/libstdc++-
v3/libsupc++ /usr/local/src/gcc-binutils/trunk/gcc/libstdc++-
v3/include/stdc++.h -O0 -g -o ./pentium4-cygwin/bits/stdc++.h.gch/O0g; \
/usr/local/src/gcc-binutils/trunk/objdir/gcc/xgcc -shared-libgcc -
B/usr/local/src/gcc-binutils/trunk/objdir/gcc/ -nostdinc++  -
L/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-v3/src -
L/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/src/.libs -B/usr/local/gcc-binutils/pentium4-cygwin/bin/ -B/usr/local/gcc-
binutils/pentium4-cygwin/lib/ -isystem /usr/local/gcc-binutils/pentium4-
cygwin/include -isystem /usr/local/gcc-binutils/pentium4-cygwin/sys-include -
L/usr/local/src/gcc-binutils/trunk/objdir/ld -Winvalid-pch -Wno-deprecated -x 
c++-header -g -O2 -nostdinc++ -I/usr/local/src/gcc-
binutils/trunk/objdir/pentium4-cygwin/libstdc++-v3/include/pentium4-cygwin -
I/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include -I/usr/local/src/gcc-binutils/trunk/gcc-binutils/libstdc++-
v3/libsupc++ /usr/local/src/gcc-binutils/trunk/gcc/libstdc++-
v3/include/stdc++.h -O2 -g -o ./pentium4-cygwin/bits/stdc++.h.gch/O2g;
/usr/local/src/gcc-binutils/trunk/gcc/libstdc++-v3/include/stdc++.h:83: 
internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray: In
   constructor `std::valarray<_Tp>::valarray() [with _Tp = size_t]':
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray:245:   instantiated from `std::valarray<_Tp>::valarray() 
[with _Tp = size_t]'
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/bits/gslice.h:86:   instantiated from here
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray:245: internal compiler error: Segmentation
   fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[4]: *** [pentium4-cygwin/bits/stdc++.h] Error 1
make[4]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3/include'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3'
make[1]: *** [all-target-libstdc++-v3] Error 2
make[1]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir'
make: *** [bootstrap-lean] Error 2

 -B/usr/local/sr
c/gcc-binutils/trunk/objdir/gcc/ -nostdinc++  -L/usr/local/src/gcc-
binutils/trun
k/objdir/pentium4-cygwin/libstdc++-v3/src -L/usr/local/src/gcc-
binutils/trunk/ob
jdir/pentium4-cygwin/libstdc++-v3/src/.libs -B/usr/local/gcc-binutils/pentium4-
c
ygwin/bin/ -B/usr/local/gcc-binutils/pentium4-cygwin/lib/ -
isystem /usr/local/gc
c-binutils/pentium4-cygwin/include -isystem /usr/local/gcc-binutils/pentium4-
cyg
win/sys-include -L/usr/local/src/gcc-binutils/trunk/objdir/ld -Winvalid-pch -
Wno
-deprecated -x c++-header -g -O2 -nostdinc++ -I/usr/local/src/gcc-
binutils/trunk
/objdir/pentium4-cygwin/libstdc++-v3/include/pentium4-cygwin -
I/usr/local/src/gc
c-binutils/trunk/objdir/pentium4-cygwin/libstdc++-v3/include -
I/usr/local/src/gc
c-binutils/trunk/gcc-binutils/libstdc++-v3/libsupc++ /usr/local/src/gcc-
binutils
/trunk/gcc/libstdc++-v3/include/stdc++.h -O2 -g -o ./pentium4-
cygwin/bits/stdc++
.h.gch/O2g;
/usr/local/src/gcc-binutils/trunk/gcc/libstdc++-v3/include/stdc++.h:83: 
internal
 compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray: In constructor `std::valarray<_Tp>::valarray() [with _Tp 
= size_t]':
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray:245:   instantiated from `std::valarray<_Tp>::valarray() 
[with _Tp = size_t]'
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/bits/gslice.h:86:   instantiated from here
/usr/local/src/gcc-binutils/trunk/objdir/pentium4-cygwin/libstdc++-
v3/include/valarray:245: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[4]: *** [pentium4-cygwin/bits/stdc++.h] Error 1
make[4]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3/include'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir/pentium4-
cygwin/libstdc++-v3'
make[1]: *** [all-target-libstdc++-v3] Error 2
make[1]: Leaving directory `/usr/local/src/gcc-binutils/trunk/objdir'
make: *** [bootstrap-lean] Error 2
Comment 1 Christian Joensson 2003-06-28 11:12:32 UTC

*** This bug has been marked as a duplicate of 11360 ***