Bug 11149 - [3.3/3.4 Regression] ICE on error when instantiation with call function of a base type
Summary: [3.3/3.4 Regression] ICE on error when instantiation with call function of a ...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3
: P2 critical
Target Milestone: 3.3.1
Assignee: Mark Mitchell
URL:
Keywords: ice-on-invalid-code, monitored
Depends on:
Blocks: 11148
  Show dependency treegraph
 
Reported: 2003-06-11 04:03 UTC by Andrew Pinski
Modified: 2004-01-17 04:22 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-07-01 00:20:46


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pinski 2003-06-11 04:03:28 UTC
compile this code:

template <typename X>
class Foo {
    int i;
public:
    Foo() {
        X::explode();
    }
};

class Bar {
    Foo<int> foo_;
public:
    Bar() {}
};

template class Foo<int>;

Since this is split, and I can confirm this on the mainline (20030610) and 3.3.1 
(20030526) and I do not see the ICE. in 3.2.3
Comment 1 Wolfgang Bangerth 2003-06-11 14:32:10 UTC
Confirmed indeed. A regression in 3.3 and mainline over 3.2.
Comment 3 CVS Commits 2003-07-01 17:36:05 UTC
Subject: Bug 11149

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	mmitchel@gcc.gnu.org	2003-07-01 17:36:00

Modified files:
	gcc/cp         : ChangeLog call.c 
	gcc/testsuite  : ChangeLog 
Added files:
	gcc/testsuite/g++.dg/lookup: scoped6.C 

Log message:
	PR c++/11149
	* call.c (resolve_scoped_fn_name): Check that the qualifying scope
	is a class type.
	
	PR c++/11149
	* g++.dg/lookup/scoped6.C: New test.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/ChangeLog.diff?cvsroot=gcc&r1=1.3476&r2=1.3477
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/call.c.diff?cvsroot=gcc&r1=1.394&r2=1.395
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.2824&r2=1.2825
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.dg/lookup/scoped6.C.diff?cvsroot=gcc&r1=1.1&r2=1.2

Comment 4 Mark Mitchell 2003-07-01 17:39:11 UTC
Fixed in GCC 3.3.1, GCC 3.4.