Bug 11084 - [3.3/3.4 regression] ICE in propagate_one_insn, at flow.c:1639
Summary: [3.3/3.4 regression] ICE in propagate_one_insn, at flow.c:1639
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.3
: P1 critical
Target Milestone: 3.3.1
Assignee: Richard Sandiford
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-06-04 02:15 UTC by Debian GCC Maintainers
Modified: 2004-01-17 04:22 UTC (History)
3 users (show)

See Also:
Host: mipsel-linux
Target: mipsel-linux
Build: mipsel-linux
Known to work:
Known to fail:
Last reconfirmed: 2003-06-23 18:20:53


Attachments
preprocessed source (25.47 KB, application/octet-stream)
2003-06-04 02:18 UTC, Debian GCC Maintainers
Details
reduced testcase.i (438 bytes, text/plain)
2003-06-05 00:20 UTC, Dara Hazeghi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2003-06-04 02:15:35 UTC
I've gotten a bunch of these errors with 3.3 that don't happen with gcc 3.2.3
20030415 (Debian prerelease).  


Reading specs from /usr/lib/gcc-lib/mipsel-linux/3.3/specs
Configured with: ../src/configure -v
--enable-languages=c,c++,f77,pascal,objc,treelang --prefix=/usr
--mandir=/usr/share/man --infodir=/usr/share/info
--with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --with-system-zlib
--enable-nls --without-included-gettext --enable-__cxa_atexit
--enable-clocale=gnu --enable-debug --enable-objc-gc mips-linux
Thread model: posix
gcc version 3.3 (Debian)

gcc -save-temps -c -g -O2 -fno-strict-aliasing -Wall -Wstrict-prototypes -I.
-I../Include -DHAVE_CONFIG_H -o Python/errors.o ../Python/errors.c
../Python/errors.c: In function `PyErr_Format':
../Python/errors.c:514: error: Attempt to delete prologue/epilogue insn:
(insn 854 656 855 0 (nil) (set (mem:SI (plus:SI (reg/f:SI 29 sp)
                (const_int 84 [0x54])) [0 S4 A32])
        (reg:SI 5 a1)) -1 (nil)
    (nil))
../Python/errors.c:514: internal compiler error: in propagate_one_insn, at
flow.c:1639
Comment 1 Debian GCC Maintainers 2003-06-04 02:18:03 UTC
Created attachment 4158 [details]
preprocessed source
Comment 2 Dara Hazeghi 2003-06-05 00:20:19 UTC
Created attachment 4171 [details]
reduced testcase.i
Comment 3 Dara Hazeghi 2003-06-05 00:22:03 UTC
Confirmed with gcc 3.3 branch and mainline (20030604). Took me a while, because this is not 
reproducible with mipsel-elf target. Hopefully the reduced testcase I've attached will help track 
this one down...

Dara
Comment 4 rsandifo@gcc.gnu.org 2003-06-23 18:13:32 UTC
With permission.  Testing a fix now.
Comment 5 rsandifo@gcc.gnu.org 2003-06-23 18:18:34 UTC
Used the wrong bugzilla option.  Let's try that again...
Comment 6 rsandifo@gcc.gnu.org 2003-06-23 18:20:53 UTC
Oh for the love of a duck. ;)  Why does changing the assignee make the
status go from ASSIGNED to NEW?
Comment 7 CVS Commits 2003-06-25 07:14:00 UTC
Subject: Bug 11084

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	rsandifo@gcc.gnu.org	2003-06-25 06:50:57

Modified files:
	gcc            : ChangeLog 
	gcc/config/mips: mips.c 
	gcc/testsuite  : ChangeLog 
Added files:
	gcc/testsuite/gcc.c-torture/compile: 20030625-1.c 

Log message:
	PR target/11084
	* config/mips/mips.c (mips_expand_prologue): Fix setting of regno
	for the end of a variable argument list.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.16114.2.614&r2=1.16114.2.615
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/mips/mips.c.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.241.2.2&r2=1.241.2.3
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.2261.2.201&r2=1.2261.2.202
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gcc.c-torture/compile/20030625-1.c.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=NONE&r2=1.1.2.1

Comment 8 rsandifo@gcc.gnu.org 2003-06-25 07:24:35 UTC
The commit message in the audit trail is for 3.3.  See:

    http://gcc.gnu.org/ml/gcc-patches/2003-06/msg02766.html

for a full description.  I submitted a different version for 3.4:

    http://gcc.gnu.org/ml/gcc-patches/2003-06/msg02768.html

However, an earlier patch means that the bug no longer causes an ICE
in 3.4 sources.  I'll go ahead and close this as fixed in both branch
and trunk.