User account creation filtered due to spam.

Bug 11062 - Please avoid __attribute__ ((unused))
Summary: Please avoid __attribute__ ((unused))
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.3
: P2 normal
Target Milestone: 3.3.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-02 11:40 UTC by richard.kreckel
Modified: 2003-07-25 16:40 UTC (History)
1 user (show)

See Also:
Host: mips-pc-linux-gnu
Target: mips-pc-linux-gnu
Build: mips-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2003-06-02 15:16:08


Attachments
Patch to fix the problem (384 bytes, patch)
2003-06-02 11:49 UTC, richard.kreckel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description richard.kreckel 2003-06-02 11:40:44 UTC
Please use __attribute__ ((__unused__)) instead, since the plain 
spelling ((unused)) without underscores might conflict with otherwise
perfectly standard-complying sources that declare "unused" somehow.
Comment 1 richard.kreckel 2003-06-02 11:49:43 UTC
Created attachment 4139 [details]
Patch to fix the problem

2003-06-02  Richard B. Kreckel	<Richard.Kreckel@GiNaC.DE>

	* config/cpu/mips/bits/atomicity.h: Change __attribute__
	((unused)) to __attribute__ ((__unused__)).
	* config/os/aix/atomicity.h: Same.
Comment 2 Andrew Pinski 2003-06-02 12:19:45 UTC
From <http://gcc.gnu.org/contribute.html>:
Patches to the standard C++ library (libstdc++-v3), and its web pages, and discussion of 
such patches, should go to libstdc++@gcc.gnu.org as well as to gcc-patches.

Can you send your patch to both gcc-patches@gcc.gnu.org and libstdc++@gcc.gnu.org?
Comment 3 richard.kreckel 2003-06-02 15:11:56 UTC
Sure, if it helps.  Welcome to the bureaucracy.
(I was under the impression that Bugzilla's patch-facility was actually being used.)
</inappropriate_remark>
Comment 4 Andrew Pinski 2003-06-02 15:16:08 UTC
Patch has been submitted: <http://gcc.gnu.org/ml/gcc-patches/2003-06/msg00112.html>.
Comment 5 Phil Edwards 2003-06-02 18:09:11 UTC
Applied to mainline (3.4) and 3.3 branches.