Bug 10969 - private struct template specialization refused (gtmm buid fails)
Summary: private struct template specialization refused (gtmm buid fails)
Status: RESOLVED DUPLICATE of bug 10849
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3
: P2 critical
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-24 14:46 UTC by casteyde.christian
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-gnu-linux
Target: i686-gnu-linux
Build: i686-gnu-linux
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description casteyde.christian 2003-05-24 14:46:36 UTC
The follwing code is rejected : 
 
class A 
{ 
private: 
        template <class T> 
        struct a 
        { 
                T i; 
        }; 
}; 
 
template <> 
struct A::a<int> 
{ 
}; 
 
int main(void) 
{ 
        return 0; 
} 
 
this kind of construciton is used by gtkmm 2.2, which do not build 
anymore with gcc 3.3 (regression from 3.2.3).
Comment 1 Kriang Lerdsuwanakij 2003-05-24 17:58:47 UTC

*** This bug has been marked as a duplicate of 10849 ***