Bug 10935 - PCH causing ICE during building of libstc++-v3
Summary: PCH causing ICE during building of libstc++-v3
Status: RESOLVED DUPLICATE of bug 11341
Alias: None
Product: gcc
Classification: Unclassified
Component: pch (show other bugs)
Version: 3.4.0
: P1 normal
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-22 15:34 UTC by edmar
Modified: 2003-07-01 14:54 UTC (History)
2 users (show)

See Also:
Host: i686-pc-cygwin
Target: powerpc-eabialtivec
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-05-26 22:31:10


Attachments
Preprocessed input that causes the ICE (122.39 KB, text/compressed)
2003-05-22 15:37 UTC, edmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description edmar 2003-05-22 15:34:09 UTC
Got the whole source tree from uberbaum. Snapshot from 20030516. Removed
directories rda, sid, and tix.
Compiler output:
Reading specs from /cygdrive/c/home/edmar/obj/gcc/specs
Configured with: ../gnupowerpc/configure --prefix=/altivec
--enable-languages=c,c++,f77 --target=powerpc-eabialtivec --host=i686-pc-cygwin
Thread model: single
gcc version 3.4 20030516 (experimental)
 /cygdrive/c/home/edmar/obj/gcc/cc1plus.exe -E -quiet -nostdinc++ -nostdinc
-nostdinc++ -v
-I/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/libstdc++-v3/include/powerpc-eabialtivec
-I/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/libstdc++-v3/include
-I../../../../../gnupowerpc/libstdc++-v3/libsupc++ -iprefix
/cygdrive/c/home/edmar/obj/gcc/../lib/gcc-lib/powerpc-eabialtivec/3.4/ -isystem
/cygdrive/c/home/edmar/obj/gcc/include -isystem
/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/newlib/include -isystem
/altivec/powerpc-eabialtivec/bin/include -isystem
/altivec/powerpc-eabialtivec/lib/include -isystem
/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/newlib/targ-include -isystem
/cygdrive/c/home/edmar/gnupowerpc/newlib/libc/include -isystem
/altivec/powerpc-eabialtivec/include -isystem
/altivec/powerpc-eabialtivec/sys-include
/cygdrive/c/home/edmar/gnupowerpc/libstdc++-v3/include/stdc++.h -msoft-float
-msoft-float -Winvalid-pch -Wno-deprecated -O2 -O0 stdc++.ii
ignoring nonexistent directory
"/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/newlib/include"
ignoring nonexistent directory "/altivec/powerpc-eabialtivec/bin/include"
ignoring nonexistent directory "/altivec/powerpc-eabialtivec/lib/include"
ignoring nonexistent directory "/altivec/powerpc-eabialtivec/sys-include"
#include "..." search starts here:
#include <...> search starts here:

/cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/libstdc++-v3/include/powerpc-eabialtivec
 /cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/libstdc++-v3/include
 ../../../../../gnupowerpc/libstdc++-v3/libsupc++
 /cygdrive/c/home/edmar/obj/gcc/include
 /cygdrive/c/home/edmar/obj/powerpc-eabialtivec/nof/newlib/targ-include
 /cygdrive/c/home/edmar/gnupowerpc/newlib/libc/include
 /altivec/powerpc-eabialtivec/include
End of search list.
 /cygdrive/c/home/edmar/obj/gcc/cc1plus.exe -fpreprocessed stdc++.ii -quiet
-dumpbase stdc++.h -msoft-float -msoft-float -auxbase stdc++ -g -g -O2 -O0
-Winvalid-pch -Wno-deprecated -version -o stdc++.s --output-pch=
./powerpc-eabialtivec/bits/stdc++.h.gch/O0g
GNU C++ version 3.4 20030516 (experimental) (powerpc-eabialtivec)
        compiled by GNU C version 3.2 20020927 (prerelease).
GGC heuristics: --param ggc-min-expand=47 --param ggc-min-heapsize=32709
Comment 1 edmar 2003-05-22 15:37:38 UTC
Created attachment 4051 [details]
Preprocessed input that causes the ICE
Comment 2 Andrew Pinski 2003-05-26 22:31:10 UTC
PCH is causing this ICE on cygwin, there might be a bug fixed for cygwin native build but 
I could not find it.
Comment 3 Andrew Pinski 2003-06-14 23:38:51 UTC
You can use this patch to disable PCH in libstdc++:
Needs this patch to disable PCH in libstdc++-v3 testsuite
--- libstdc++-v3/testsuite_flags.in  26 Apr 2003 04:01:47 -0000      1.17
+++ libstdc++-v3/testsuite_flags.in  7 May 2003 02:37:34 -0000
@@ -43,7 +43,7 @@
       echo \${CXX}
       ;;
     --build-cxx)
-      PCHFLAGS="-include bits/stdc++.h"
+      PCHFLAGS= #"-include bits/stdc++.h"
       CXX_build="@glibcpp_CXX@ \${PCHFLAGS}"
       CXX=\`echo "\$CXX_build" | sed 's,gcc/xgcc ,gcc/g++ ,'\`
       echo \${CXX}
Comment 4 Andrew Pinski 2003-07-01 14:54:12 UTC
This is a dup of bug 11341 which has more information in it.

*** This bug has been marked as a duplicate of 11341 ***