Bug 10748 - Livelock regression in GCJ 3.3
Summary: Livelock regression in GCJ 3.3
Status: RESOLVED DUPLICATE of bug 10746
Alias: None
Product: gcc
Classification: Unclassified
Component: libgcj (show other bugs)
Version: 3.3
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-12 12:46 UTC by oyvind.harboe
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Debug session (94.11 KB, image/pjpeg)
2003-08-21 07:23 UTC, oyvind.harboe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oyvind.harboe 2003-05-12 12:46:03 UTC
This mailing list entry describes the problem.

This problem is new with GCJ 3.3, 3.2 works fine.

I'm struggling with PR 10746, and before that is resolved, producing an easily reproducable case to fit into this report is going to be difficult.

I thought I'd report this problem regardless.


http://gcc.gnu.org/ml/java/2003-02/msg00511.html

Release:
GCJ 3.3
Comment 1 oyvind.harboe 2003-08-21 07:23:34 UTC
Created attachment 4627 [details]
Debug session

This is a snapshot from the debugger. As you can see getClass() is trying to
access address 0.

Presumably it is trying to fish out the vtable from the class object...

Øyvind
Comment 2 Andrew Pinski 2003-10-11 02:41:40 UTC
Does this happen on the mainline after bug 10746 was fixed?
Comment 3 oyvind.harboe 2003-10-11 10:51:23 UTC
T

*** This bug has been marked as a duplicate of 10746 ***