Bug 10695 - ICE in dwarf2out_frame_debug_expr,
Summary: ICE in dwarf2out_frame_debug_expr,
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: debug (show other bugs)
Version: 3.3
: P2 normal
Target Milestone: 3.4.2
Assignee: Richard Henderson
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-05-09 06:06 UTC by rmurray
Modified: 2004-08-26 09:16 UTC (History)
2 users (show)

See Also:
Host: alpha-linux
Target: alpha-linux
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-05-12 22:30:12


Attachments
wordsedit.ii.bz2 (128.59 KB, application/octet-stream)
2003-05-21 15:17 UTC, rmurray
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmurray 2003-05-09 06:06:00 UTC
ICE while building wordsedit.cpp of agistudio 1.1 on alpha, happens with 2.95, 3.2.3, and 3.3.

g++ -c -pipe -Wall -W -g -D_REENTRANT -DQT_THREAD_SUPPORT -I/usr/include/qt3 -I/usr/include/qt -o wordsedit.o wordsedit.cpp
wordsedit.cpp: In member function `void WordsEdit::merge_file()':
wordsedit.cpp:620: Internal compiler error in dwarf2out_frame_debug_expr, at dwarf2out.c:1328
Please submit a full bug report,

2.95 includes this as well, 3.2 and 3.3 don't:
{standard input}: Assembler messages:
{standard input}:9212: Warning: missing .end or .bend at end of file

Release:
3.2.3, 3.3 20030410 (prerelease), 2.95.4 20011002 (Debian prerelease)

Environment:
Reading specs from /usr/lib/gcc-lib/alpha-linux/3.2.3/specs
Configured with: ../src/configure -v --enable-languages=c,c++,java,f77,objc,ada --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-gxx-include-dir=/usr/include/c++/3.2 --enable-shared --with-system-zlib --enable-nls --without-included-gettext --enable-__cxa_atexit --enable-clocale=gnu --enable-java-gc=boehm --enable-objc-gc alpha-linux
Thread model: posix
Comment 1 falk.hueffner 2003-05-09 17:54:03 UTC
From: Falk Hueffner <falk.hueffner@student.uni-tuebingen.de>
To: rmurray@debian.org
Cc: gcc-gnats@gcc.gnu.org, 192568@bugs.debian.org
Subject: Re: c++/10695: 2.95/3.2/3.3: ICE on alpha while building agistudio
Date: 09 May 2003 17:54:03 +0200

 rmurray@debian.org writes:
 
 > g++ -c -pipe -Wall -W -g -D_REENTRANT -DQT_THREAD_SUPPORT -I/usr/include/qt3 -I/usr/include/qt -o wordsedit.o wordsedit.cpp
 > wordsedit.cpp: In member function `void WordsEdit::merge_file()':
 > wordsedit.cpp:620: Internal compiler error in dwarf2out_frame_debug_expr, at dwarf2out.c:1328
 > Please submit a full bug report,
 
 This is acually a bug in the Debian package, because the file isn't
 compiled with -O2 as policy mandates, and the error only occurs at -O0
 ;)
 
 Here's a test case:
 
 struct WordList {
     char c[320000];
 };
 
 void merge(struct WordList);
 
 void merge_file()
 {
     struct WordList w;
     merge(w);
 }
 
 The problem is still there in g++ 3.4 20030423. It also occurs with
 gcc -g.
 
 The author should probably also consider not passing 320k large
 structures by value...
 
 -- 
 	Falk
Comment 2 Dara Hazeghi 2003-05-31 20:05:38 UTC
Don't know why bugzilla doesn't consider this confirmed... BTW, doesn't this bug more likely 
belong under "target"? Thanks,

Dara
Comment 3 rmurray 2003-08-09 15:49:43 UTC
still happens with 3.3.1
Comment 4 Dara Hazeghi 2004-01-18 07:43:06 UTC
Still present on mainline.
Comment 5 Dara Hazeghi 2004-05-12 22:30:12 UTC
Still present on tree-ssa.
Comment 6 CVS Commits 2004-08-26 09:05:43 UTC
Subject: Bug 10695

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	rth@gcc.gnu.org	2004-08-26 09:05:33

Modified files:
	gcc            : ChangeLog 
	gcc/config/alpha: alpha.c 

Log message:
	PR debug/10695
	* config/alpha/alpha.c (emit_frame_store_1, emit_frame_store): New.
	(alpha_expand_prologue): Handle >32-bit frames.  Generate proper
	unwind info for >16-bit frames.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=2.2326.2.597&r2=2.2326.2.598
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/alpha/alpha.c.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.342.4.10&r2=1.342.4.11

Comment 7 CVS Commits 2004-08-26 09:08:16 UTC
Subject: Bug 10695

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	rth@gcc.gnu.org	2004-08-26 09:08:12

Modified files:
	gcc            : ChangeLog 
	gcc/config/alpha: alpha.c 

Log message:
	PR debug/10695
	* config/alpha/alpha.c (emit_frame_store_1, emit_frame_store): New.
	(alpha_expand_prologue): Handle >32-bit frames.  Generate proper
	unwind info for >16-bit frames.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=2.5101&r2=2.5102
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/config/alpha/alpha.c.diff?cvsroot=gcc&r1=1.391&r2=1.392

Comment 8 Richard Henderson 2004-08-26 09:09:56 UTC
Fixed.
Comment 9 Richard Henderson 2004-08-26 09:16:29 UTC
No, really.  Fixed.