Bug 10636 - configuration mismatch with mempcpy
Summary: configuration mismatch with mempcpy
Status: RESOLVED DUPLICATE of bug 10140
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-06 04:56 UTC by steveu
Modified: 2003-06-12 00:03 UTC (History)
3 users (show)

See Also:
Host: i686-pc-cygwin
Target: i686-pc-cygwin
Build: i686-pc-cygwin
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steveu 2003-05-06 04:56:00 UTC
The ./configure configuration of GCC looks for the existance of the function mempcpy, and if found sets HAVE_MEMPCPY. However the function which is actually used in gcc/fixinc/gnu-regex.c (I don't think it occurs anywhere else) is __mempcpy. This works on most systems, which have both __mempcpy and mempcpy. The latest cygwin only has mempcpy, and   shows up the bug. gcc needs a little patching to make it build.

Release:
3.2.3

Environment:
cygwin
Comment 1 steveu 2003-05-06 04:56:00 UTC
Fix:
Look for either __mempcpy or mempcpy. Set and use separate variables,depending on the outcome. That seems the bullet proof approach.
Comment 2 Dara Hazeghi 2003-05-16 17:58:47 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: steveu@coppice.org, gcc-gnats@gcc.gnu.org, nobody@gcc.gnu.org
Cc:  
Subject: Re: bootstrap/10636: configuration mismatch with mempcpy
Date: Fri, 16 May 2003 17:58:47 -0700

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=10636
 
 Hello,
 
 looking at gnu-regex.c on gcc 3.3 and mainline, I don't see any  
 reference to __mempcpy, only mempcpy. Does this mean that the problem  
 is solved? Would it be possible for you to check if this problem is  
 still exhibited with gcc 3.3? Thanks,
 
 Dara
 
Comment 3 Giovanni Bajo 2003-05-17 06:55:11 UTC
State-Changed-From-To: open->feedback
State-Changed-Why: See Dara's question.
Comment 4 Dara Hazeghi 2003-06-08 03:57:32 UTC
Giovanni, you bootstrap cygwin, correct? If so, do you know what the status of this is? Thanks,

Dara
Comment 5 Giovanni Bajo 2003-06-09 18:07:39 UTC
Yes, it's a known problem which was fixed by Kaveh before 3.3 but after 3.2.3. 
It used to be tracked by PR10140.

*** This bug has been marked as a duplicate of 10140 ***