Bug 10587 - [3.3/3.4 regression] [ia64] ICE in copy_to_mode_reg compiling libquicktime
Summary: [3.3/3.4 regression] [ia64] ICE in copy_to_mode_reg compiling libquicktime
Status: RESOLVED DUPLICATE of bug 10700
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.2.3
: P3 normal
Target Milestone: 3.3.1
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-05-01 20:56 UTC by 189365
Modified: 2004-01-17 04:22 UTC (History)
1 user (show)

See Also:
Host: ia64-debian-linux
Target: ia64-debian-linux
Build: ia64-debian-linux
Known to work:
Known to fail:
Last reconfirmed: 2003-06-02 00:28:00


Attachments
mot_est_mb.i.gz (14.52 KB, application/x-gzip )
2003-05-21 15:17 UTC, 189365
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 189365 2003-05-01 20:56:02 UTC
[ Reported to the Debian BTS as report #189365.
  Please CC 189365@bugs.debian.org on replies.
  Log of report can be found at http://bugs.debian.org/189365 ]
	

Rechecked with gcc-3.2.3 and 3.3 CVS 20030429

The libquicktime package fails on the ia64 autobuilder with an internal
compiler error, as shown below.  A previous version of libquicktime 
successfully compiled with an unknown (but probably older) version of gcc.
[I don't know the version that correctly compiled libquicktime]

gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../include/quicktime -O3 -funroll-all-loops -fomit-frame-pointer -finline-functions -W -Wall -Wno-unused -Winline -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -c mot_est_mb.c -MT mot_est_mb.lo -MD -MP -MF .deps/mot_est_mb.TPlo  -fPIC -DPIC -o .libs/mot_est_mb.lo
mot_est_mb.c: In function `MBMotionEstimation':
mot_est_mb.c:614: Internal compiler error in copy_to_mode_reg, at explow.c:725
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

Same with reducing the options to -O0

Attaching the source in a followup

Release:
unknown
Comment 1 Dara Hazeghi 2003-05-25 06:51:01 UTC
Hello,

I can reproduce the error in this report on gcc 3.1, 3.2.3, 3.3 branch and mainline (20030514) on 
ia64-hpux cross. Could you check what version it was that this did compile correctly under? 
Thanks,

Dara
Comment 2 Matthias Klose 2003-06-01 14:38:56 UTC
Subject: Re: Bug#189365:  [3.2/3.3 regression] [ia64] ICE in copy_to_mode_reg compiling libquicktime

dhazeghi@yahoo.com writes:
> I can reproduce the error in this report on gcc 3.1, 3.2.3, 3.3 branch and mainline (20030514) on 
> ia64-hpux cross. Could you check what version it was that this did compile correctly under? 

Not exactly, the last successful build was
http://buildd.debian.org/fetch.php?&pkg=libquicktime&ver=0.9.2pre1-6&arch=ia64&stamp=1048877462&file=log&as=raw

As the autobuilders use recent packages, I assume gcc-3.2.3 prerelease (CVS 20030316)
Comment 3 Dara Hazeghi 2003-06-02 00:28:00 UTC
Okay, thanks. Hopefully that information will help somebody figure out where that regression 
crept in from...

Dara
Comment 4 Falk Hueffner 2003-06-17 22:09:41 UTC

*** This bug has been marked as a duplicate of 10700 ***