User account creation filtered due to spam.

Bug 10504 - [3.3] ICE with SSE2 code and -O3 -mcpu=pentium4 -msse2
Summary: [3.3] ICE with SSE2 code and -O3 -mcpu=pentium4 -msse2
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.3
: P3 normal
Target Milestone: 3.3.1
Assignee: Jan Hubicka
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2003-04-25 17:36 UTC by gbvalor
Modified: 2003-07-21 19:09 UTC (History)
3 users (show)

See Also:
Host:
Target: pentium4-pc-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
sse2test.tar.gz (13.36 KB, application/x-gzip )
2003-05-21 15:17 UTC, gbvalor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gbvalor 2003-04-25 17:36:09 UTC
ICE when trying to compile code with calls to SSE2 Intel intrinsic library. Any combination ofoptimizing flag -Ox with -mcpu=pentium4 -march=pentium4 -msse2 generate an ICE.

The output is:
> gcc-3.3 -save-temps -O3 -mcpu=pentium4 -march=pentium4 -msse2 sse2test.c -o sse2test
sse2test.c: En la función `main':
sse2test.c:94: internal compiler error: in simplify_unary_operation, at simplify-rtx.c:387
Por favor envíe un reporte completo de `bugs',
con el código preprocesado si es apropiado.
Vea <URL:http://gcc.gnu.org/bugs.html> para más instrucciones.


Attached is sse2test.tar.gz with 'sse2test.c' and 'sse2test.i' files

Release:
gcc versión 3.3 20030424 (prerelease)

Environment:
pentium4-pc-linux-gnu; Kernel-2.4.19, SuSE-linux 8.1

How-To-Repeat:
Try to compile the code with -O3 -mcpu=pentium4 -march=pentium4 -msse2 flags
Comment 1 Wolfgang Bangerth 2003-04-25 18:25:05 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Confirmed. Problem exists in 3.3, but 3.4 works. 3.2.x never
    really supported sse2, so this is not a regression.
    
    W.
Comment 2 gbv 2003-05-18 11:11:16 UTC
From: Guillermo Ballester Valor <gbv@oxixares.com>
To: gcc-prs@gcc.gnu.org, gbvalor@oxixares.com, gcc-bugs@gcc.gnu.org,
	gcc-gnats@gcc.gnu.org, nobody@gcc.gnu.org
Cc:  
Subject: Re: target/10504: [3.3] ICE with SSE2 code and -O3 -mcpu=pentium4 -msse2
Date: Sun, 18 May 2003 11:11:16 +0200

 Hi,
 
 I am the guy who reported the bug. I only would like to add that the bug 
 should be introduced recently. Precisely, the gcc version used by SuSE 8.2 
 does not show any problem:
 
 gcc (GCC) 3.3 20030226 (prerelease) (SuSE Linux)
 Copyright (C) 2002 Free Software Foundation, Inc.
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 
 OTOH, I tried with the 3.3 release and the problem is still here. 
 
 Hope this helps.  
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=10504
 
 Guillermo
 -- 
 Guillermo Ballester Valor
 gbv@oxixares.com
 Ogijares, Granada  SPAIN
  
Comment 3 Wolfgang Bangerth 2003-05-20 19:04:25 UTC
Responsible-Changed-From-To: unassigned->hubicka
Responsible-Changed-Why: Jan, I think this is your field, right?
    Thanks
      W.
Comment 4 gbv 2003-05-21 20:55:12 UTC
Hi, 
 
So, when this GCC 3.4 patch backported will be commited to the 3.3 CVS branch ? 
 
Guillermo. 
Comment 5 Steven Bosscher 2003-07-12 00:11:13 UTC
This is apparently fixed for mainline, and it is an ice-on-valid-code; also,
this PR is only in the FSF release, not in the SuSE prerelease they use for SuSE
8.2.  Probably Jan's fix was in the SuSE tree all along, which would mean this
is well-tested and therefore safe for 3.3.1.  Is there stil ltime for a backport?
Comment 6 Mark Mitchell 2003-07-13 20:07:59 UTC
Subject: Re:  [3.3] ICE with SSE2 code and -O3
	-mcpu=pentium4 -msse2

On Fri, 2003-07-11 at 17:11, steven at gcc dot gnu dot org wrote:
> PLEASE REPLY TO gcc-bugzilla@gcc.gnu.org ONLY, *NOT* gcc-bugs@gcc.gnu.org.
> 
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=10504
> 
> 
> steven at gcc dot gnu dot org changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |mark at codesourcery dot com
> 
> 
> ------- Additional Comments From steven at gcc dot gnu dot org  2003-07-12 00:11 -------
> This is apparently fixed for mainline, and it is an ice-on-valid-code; also,
> this PR is only in the FSF release, not in the SuSE prerelease they use for SuSE
> 8.2.  Probably Jan's fix was in the SuSE tree all along, which would mean this
> is well-tested and therefore safe for 3.3.1.  Is there stil ltime for a backport?

Yes, and it would be great to do that!

Comment 7 Jan Hubicka 2003-07-21 19:09:57 UTC
Fixed by my earlier patch