Bug 10267 - Wrong build instructions for *-*-solaris2*
Summary: Wrong build instructions for *-*-solaris2*
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.2.2
: P3 normal
Target Milestone: ---
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-30 10:06 UTC by Hallvard B Furuseth
Modified: 2003-07-25 17:33 UTC (History)
1 user (show)

See Also:
Host: sparc-sun-solaris2.8
Target: sparc-sun-solaris2.8
Build: sparc-sun-solaris2.8
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hallvard B Furuseth 2003-03-30 10:06:00 UTC
	INSTALL/specific.html#*-*-solaris2* says one should set
	CONFIG_SHELL to /bin/ksh for configure.  However, it is
	also needed during make bootstrap, since it is bootstrap
	which configures libstdc++-v3.

Release:
3.2.2

Environment:
System: SunOS bombur.uio.no 5.8 Generic_108528-13 sun4u sparc SUNW,Ultra-5_10
Architecture: sun4

	
host: sparc-sun-solaris2.8
build: sparc-sun-solaris2.8
target: sparc-sun-solaris2.8
configured with: ../gcc-3.2.2/configure --enable-languages=c,c++,f77 --prefix=/usit/bombur/hbf --enable-version-specific-runtime-libs --enable-threads

How-To-Repeat:
	env CONFIG_SHELL=/bin/ksh ../gcc-3.2.2/configure
	make -s bootstrap
    Output:
	...
	loading cache ../config.cache within ltconfig
	configure: error: libtool configure failed
	make[1]: *** [configure-target-libstdc++-v3] Error 1
	make: *** [bootstrap] Error 2
Comment 1 Hallvard B Furuseth 2003-03-30 10:06:00 UTC
Fix:
	"... set CONFIG_SHELL to /bin/ksh in your environment before
	running configure and 'make bootstrap'."

	I also suggest to remove the 'If you encounter this problem'
	phrase since it takes two hours before one encounters it.
	Try 'Therefore, we suggest you set CONFIG_SHELL...'.
Comment 2 Gerald Pfeifer 2003-04-01 22:06:07 UTC
Responsible-Changed-From-To: unassigned->gerald
Responsible-Changed-Why: I'll take that one and try to cook up a patch.
Comment 3 Gerald Pfeifer 2003-04-01 22:06:07 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Confirmed.
Comment 4 Gerald Pfeifer 2003-04-05 15:48:35 UTC
From: gerald@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: bootstrap/10267
Date: 5 Apr 2003 15:48:35 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Changes by:	gerald@gcc.gnu.org	2003-04-05 15:48:35
 
 Modified files:
 	gcc            : ChangeLog 
 	gcc/doc        : install.texi 
 
 Log message:
 	PR bootstrap/10267
 	* doc/install.texi (*-*-solaris2): /bin/ksh is not just recommended
 	for configuring.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=1.17332&r2=1.17333
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/doc/install.texi.diff?cvsroot=gcc&r1=1.178&r2=1.179
 

Comment 5 Gerald Pfeifer 2003-04-05 15:49:40 UTC
From: gerald@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: bootstrap/10267
Date: 5 Apr 2003 15:49:40 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Branch: 	gcc-3_3-branch
 Changes by:	gerald@gcc.gnu.org	2003-04-05 15:49:39
 
 Modified files:
 	gcc            : ChangeLog 
 	gcc/doc        : install.texi 
 
 Log message:
 	PR bootstrap/10267
 	* doc/install.texi (*-*-solaris2): /bin/ksh is not just recommended
 	for configuring.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.16114.2.405&r2=1.16114.2.406
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/doc/install.texi.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.151.2.24&r2=1.151.2.25
Comment 6 Gerald Pfeifer 2003-04-05 15:51:23 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Patch committed:
    http://gcc.gnu.org/ml/gcc-patches/2003-04/msg00323.html